plist.js before 5.0.1 Uncontrolled Resource Consumption via Binary Parser
plist.js versions before 5.0.1 (npm package 'plist') can exhaust memory in the binary property-list parser and crash a Node.js process. Fixed in 5.0.1.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 5.0.1
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 5.0.1.
- Last modified
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 26/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Unclear
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
The plist.js npm package ('plist') before 5.0.1 has a flaw in its binary property-list parser that lets an unauthenticated attacker remotely crash a Node.js process by sending a small, specially crafted binary plist file, causing a denial of service. The bug is a resource consumption issue, so an attacker can only disrupt availability, not read or change data.
Read the original description
plist.js (npm package 'plist') before 5.0.1 contains an uncontrolled resource consumption vulnerability in the binary property-list parser (parseBinary) that allows unauthenticated attackers to crash a Node.js process by exploiting unmemoized recursive resolution of shared object references for arrays and dictionaries. Attackers can craft a small binary plist (under 200 bytes) containing chained self-referencing object indices to trigger exponential (2^N) resolution calls and memory growth, causing an unrecoverable out-of-memory crash and denial of service.
cve.now Index
- Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
- Exposure17/25No login or user action needed, reachable over the network without a login · Unknown: Advisories don't say whether default setups are affected
- Reach?/20Unknown. No tracked technology or package matched
- Severity8.7/10CVSS 8.7
- No patch0/5No signal
What would change the score
- Would score about 71 if added to CISA KEV
- Would score about 66 if CISA's SSVC rates exploitation active
- Would score about 31 if advisories confirm default setups are exposed
What to do
Upgrade to a fixed version: 5.0.1.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- TooTallNate plist.js
fixed in 5.0.1
Evidence 3
- Patch
- Repository
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-124078
Is CVE-2026-124078 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
The binary property-list parser (parseBinary) does not limit resource use, so parsing certain binary plist input can run the Node.js process out of memory and crash it, causing a denial of service.Source: vulncheck.com
Which versions are affected by CVE-2026-124078?
plist.js: before 5.0.1.Source: cve.now feed data
Am I affected, and how do I check?
The npm package plist (plist.js) before 5.0.1 is affected, and the flaw is in its binary parser, parseBinary. To check an installed copy, run npm ls plist in the project or look at the plist version listed in its package-lock.json.Source: vulncheck.com
How do I fix CVE-2026-124078?
Upgrade the plist package to 5.0.1 or later.Source: vulncheck.com