imgproxy 3.3.0 before 4.0.16 Memory Exhaustion DoS via ICO Loader
Affects imgproxy 3.3.0 through 4.0.15 when it processes attacker-supplied ICO files through its ICO loader. Fixed in 4.0.16.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 4.0.16
- Who is exposed
- Default setups
Do first: Check every install: default setups are affected.
- Published
- Last modified
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 41/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Default setups
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
imgproxy from 3.3.0 before 4.0.16 contains an unbounded memory allocation vulnerability in the ICO loader that fails to validate the data_size field. Attackers can supply a crafted 23-byte ICO file declaring a ~4GB data_size to trigger memory exhaustion and worker crashes without authentication.
cve.now Index
- Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
- Exposure22/25Default setups, reachable over the network without a login
- Reach10/20Affects Go packages
- Severity8.7/10CVSS 8.7
- No patch0/5No signal
What would change the score
- Would score about 81 if added to CISA KEV
- Would score about 76 if CISA's SSVC rates exploitation active
What to do
Check every install: default setups are affected.
Upgrade to a fixed version: 4.0.16.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- imgproxy imgproxy
From 3.3.0 · fixed in 4.0.16
All versions
No fix released. The latest release, v2.2.11+incompatible, is still affected.
All versions
No fix released. The latest release, v2.17.0, is still affected.
From 3.3.0
No fix released. The latest release, v3.31.4, is still affected.
fixed in 4.0.16
From 3.3.0 · fixed in 4.0.16
Evidence 2
- Advisory
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-123616
Is CVE-2026-123616 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
A single crafted 23-byte ICO file makes an imgproxy worker attempt a roughly 4GB memory allocation. This can crash workers on memory-constrained hosts, or exhaust memory when the requests are repeated.Source: github.com
Which versions are affected by CVE-2026-123616?
imgproxy: from 3.3.0 before 4.0.16. github.com/imgproxy/imgproxy (Go): all versions. github.com/imgproxy/imgproxy/v2 (Go): all versions. github.com/imgproxy/imgproxy/v3 (Go): from 3.3.0. github.com/imgproxy/imgproxy/v4 (Go): before 4.0.16. 1 more package is listed on the page.Source: cve.now feed data
Am I affected, and how do I check?
Versions 3.3.0 through 4.0.15 are affected, and the problem requires imgproxy to process an attacker-supplied ICO file through its ICO loader. The proof of concept used local file sources with a filesystem root, so check the imgproxy version and whether IMGPROXY_ENABLE_LOCAL_FILES and IMGPROXY_LOCAL_FILESYSTEM_ROOT are set.Source: github.com
How do I fix CVE-2026-123616?
Upgrade to imgproxy 4.0.16, which is the listed fixed version for the affected ranges.Source: github.com