imgproxy 4.0.0 before 4.0.16 Heap Buffer Overflow via ICO Loader Integer Overflow
Affects imgproxy 4.0.0 through 4.0.15 when the ICO image loader processes a crafted ICO image. Fixed in 4.0.16.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 4.0.16
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 4.0.16.
- Published
- Last modified
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 36/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Unclear
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
imgproxy from 4.0.0 before 4.0.16 contains an integer overflow in the ICO loader that allows remote attackers to trigger a heap buffer overflow via a crafted data_size value. Attackers can submit a crafted ICO image whose data_size wraps the allocation in vips/icoload.c, corrupting heap memory to crash the process or achieve code execution.
cve.now Index
- Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
- Exposure17/25No login or user action needed, reachable over the network without a login · Unknown: Advisories don't say whether default setups are affected
- Reach10/20Affects Go packages
- Severity9.3/10CVSS 9.3
- No patch0/5No signal
What would change the score
- Would score about 81 if added to CISA KEV
- Would score about 76 if CISA's SSVC rates exploitation active
- Would score about 41 if advisories confirm default setups are exposed
What to do
Upgrade to a fixed version: 4.0.16.
Timeline
- CVE published
- First seen by cve.now
- Posted on X by cve.now
Affected versions
- imgproxy imgproxy
From 4.0.0 · fixed in 4.0.16
From 4.0.0 · fixed in 4.0.16
No fix released. The advisory names 4.0.16 as the fix, which the registry doesn't have yet.
From 4.0.0 · fixed in 4.0.16
No fix released. The advisory names 4.0.16 as the fix, which the registry doesn't have yet.
From 4.0.0 · fixed in 4.0.16
No fix released. The advisory names 4.0.16 as the fix, which the registry doesn't have yet.
Evidence 2
- Advisory
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-123614
Is CVE-2026-123614 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
The ICO loader adds a header length to a 32-bit data_size value, and for very large values the sum wraps around before memory is allocated. This leads to a heap buffer overflow. A crafted ICO image can crash the imgproxy process handling it or potentially lead to remote code execution through heap corruption.Source: vulncheck.com, github.com
Which versions are affected by CVE-2026-123614?
imgproxy: from 4.0.0 before 4.0.16. github.com/imgproxy/imgproxy/v3 (Go): from 4.0.0 before 4.0.16. github.com/imgproxy/imgproxy/v2 (Go): from 4.0.0 before 4.0.16. github.com/imgproxy/imgproxy (Go): from 4.0.0 before 4.0.16.Source: cve.now feed data
Am I affected, and how do I check?
imgproxy versions 4.0.0 through 4.0.15 are affected, and the flaw applies when the ICO image loader processes an image whose data_size exceeds UINT32_MAX minus 14. Check the running imgproxy version against that range.Source: vulncheck.com, github.com
How do I fix CVE-2026-123614?
Upgrade to imgproxy 4.0.16 or later, which contains the fix.Source: vulncheck.com, github.com