Heap-based Buffer Overflow in Babelfish for PostgreSQL TDS Prelogin Parser
- Exploited
- No known exploitation
- Fix
- Fixed in 1.5.5, 1.17.2, 2.3.5, 2.12.4, 2.13.3, and 19 more
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 1.5.5, 1.17.2, 2.3.5, 2.12.4, 2.13.3, or one of 19 more.
- Last modified
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 30/100 · provisional
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: yes
- Technical impact: total
Summary
A heap-based buffer overflow in the Babelfish for PostgreSQL extension, including the version bundled with Amazon Aurora PostgreSQL, lets a remote attacker run arbitrary operating system commands as the database process user by sending a specially crafted malformed TDS prelogin packet to the TDS port. The attack can be carried out remotely over the network without logging in and without any user action.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
Read the original description
A heap-based buffer overflow in the TDS prelogin parser in the Babelfish for PostgreSQL extension versions 1.0-1.5, 2.1-2.15, 3.1-3.12, 4.0-4.8, 5.1-5.4 and in Amazon Aurora PostgreSQL with Babelfish might allow remote attackers to execute arbitrary OS commands as the database process user via a specially crafted malformed TDS prelogin packet to the TDS port. This record consolidates a related NULL-pointer-dereference finding in the same prelogin parser.
To remediate this issue, we recommend users upgrade to Babelfish for PostgreSQL extension versions 4.10, 5.6, 6.1 or later. As a workaround, restrict network access to the TDS port (default 1433). Customers using Amazon Aurora PostgreSQL with Babelfish should upgrade their cluster to Aurora PostgreSQL 13.9.16 (1.5.5), 13.23.3 (1.17.2), 14.6.16 (2.3.5), 14.17.8 (2.12.4), 14.18.6 (2.13.3), 14.19.5 (2.14.2), 14.20.5 (2.15.2), 14.22.3 (2.16.1), 14.23.1 (2.17.0), 15.10.8 (3.8.4), 15.12.8 (3.9.4), 15.13.6 (3.10.3), 15.14.5 (3.11.2), 15.15.5 (3.12.2), 15.17.3 (3.13.1), 15.18.1 (3.14.0), 16.8.8 (4.5.5), 16.9.6 (4.6.3), 16.10.5 (4.7.2), 16.11.5 (4.8.2), 16.13.3 (4.9.1), 16.14.1 (4.10.0), 17.4.8 (5.1.4), 17.5.6 (5.2.3), 17.6.5 (5.3.2), 17.7.5 (5.4.2), 17.9.3 (5.5.1), 17.10.1 (5.6.0), 18.3.4 (6.0.2), 18.4.1 (6.1.0) or later, and apply any pending maintenance to ensure they are on the latest patch.
cve.now Index
- Exploitation0/40No signal
- Exposure20/25No login or user action needed per the CVSS vector, CISA rates it automatable · Unknown: No advisory context yet
- Reach?/20Unknown. No tracked technology or package matched
- Severity10/10CVSS 9.8, total technical impact per CISA
- No patch0/5No signal
What would change the score
- Would score about 75 if added to CISA KEV
- Would score about 70 if CISA's SSVC rates exploitation active
- Would score about 35 if advisories confirm default setups are exposed
What to do
Upgrade to a fixed version: 1.5.5, 1.17.2, 2.3.5, 2.12.4, 2.13.3, or one of 19 more.
Timeline
- CVE published
- First seen by cve.now
- Posted on X by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: yes · Technical impact: total
- Record last updated
Affected versions
- AWS babelfish-for-postgresql
From 1.0 · through 1.5; From 2.1 · through 2.15; From 3.1 · through 3.12; From 4.0 · through 4.8; From 5.1 · through 5.4
- Amazon Amazon Aurora PostgreSQL with Babelfish
From 1.0.0 · fixed in 1.5.5; From 1.6.0 · fixed in 1.17.2; From 2.0.0 · fixed in 2.3.5; From 2.4.0 · fixed in 2.12.4; From 2.13.0 · fixed in 2.13.3; From 2.14.0 · fixed in 2.14.2; From 2.15.0 · fixed in 2.15.2; From 2.16.0 · fixed in 2.16.1; From 3.0.0 · fixed in 3.8.4; From 3.9.0 · fixed in 3.9.4; From 3.10.0 · fixed in 3.10.3; From 3.11.0 · fixed in 3.11.2; From 3.12.0 · fixed in 3.12.2; From 3.13.0 · fixed in 3.13.1; From 4.0.0 · fixed in 4.5.5; From 4.6.0 · fixed in 4.6.3; From 4.7.0 · fixed in 4.7.2; From 4.8.0 · fixed in 4.8.2; From 4.9.0 · fixed in 4.9.1; From 5.0.0 · fixed in 5.1.4; From 5.2.0 · fixed in 5.2.3; From 5.3.0 · fixed in 5.3.2; From 5.4.0 · fixed in 5.4.2; From 6.0.0 · fixed in 6.0.2
Evidence 4
- Advisory
- Patch
- Patch
- Patch
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-119923
Is CVE-2026-119923 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
Which versions are affected by CVE-2026-119923?
babelfish-for-postgresql: from 1.0 through 1.5; from 2.1 through 2.15; from 3.1 through 3.12; from 4.0 through 4.8; from 5.1 through 5.4. Amazon Aurora PostgreSQL with Babelfish: from 1.0.0 before 1.5.5; from 1.6.0 before 1.17.2; from 2.0.0 before 2.3.5; from 2.4.0 before 2.12.4; from 2.13.0 before 2.13.3; from 2.14.0 before 2.14.2; from 2.15.0 before 2.15.2; from 2.16.0 before 2.16.1; from 3.0.0 before 3.8.4; from 3.9.0 before 3.9.4; from 3.10.0 before 3.10.3; from 3.11.0 before 3.11.2; from 3.12.0 before 3.12.2; from 3.13.0 before 3.13.1; from 4.0.0 before 4.5.5; from 4.6.0 before 4.6.3; from 4.7.0 before 4.7.2; from 4.8.0 before 4.8.2; from 4.9.0 before 4.9.1; from 5.0.0 before 5.1.4; from 5.2.0 before 5.2.3; from 5.3.0 before 5.3.2; from 5.4.0 before 5.4.2; from 6.0.0 before 6.0.2.Source: cve.now feed data
How do I fix CVE-2026-119923?
Upgrade to a fixed version: 1.5.5, 1.17.2, 2.3.5, 2.12.4, 2.13.3, or one of 19 more.Source: cve.now feed data