Improper isolation of shared resources in aws-network-policy-agent in Amazon EKS
Affects aws-network-policy-agent before 1.3.7 and the Amazon VPC CNI Managed Add-on before 1.22.3 in Amazon EKS. Fixed in aws-network-policy-agent 1.3.7 and Amazon VPC CNI 1.22.3.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 1.3.7, 1.22.3
- Who is exposed
- Specific setups only
Do first: Check whether your setup matches what the bug needs. Impacted if aws-network-policy-agent is below 1.3.7 or Amazon VPC CNI Managed Add-on is below 1.22.3
- Exploitation?/40Exploitation: unknown (data gap). No CISA SSVC exploitation rating yet
- Exposure5/25Specific setups only
- Reach?/20Reach: unknown (data gap). No tracked technology or package matched
- Severity8.7/10CVSS 8.7
- No patch0/5No signal
What would change the score
- Would score about 64 if added to CISA KEV
- Would score about 59 if CISA's SSVC rates exploitation active
- Would score about 24 if CISA's SSVC rates it automatable
CVE-2026-122266 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.7 (high) and affects aws-network-policy-agent and amazon-vpc-cni-k8s; fixed in 1.3.7 and 1.22.3.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 14/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in 1.3.7, 1.22.3
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Software: aws-network-policy-agent in Amazon EKS, which is the Network Policy Agent used by VPC CNI. An attacker who is adjacent to the network and holds a low-privilege login can bypass NetworkPolicy ingress enforcement on co-located pods by poisoning the eBPF conntrack map with crafted AF_PACKET frames. The attack needs no user interaction, and the advisory does not state a non-default setup.
Read the original description
Improper isolation of shared resources in aws-network-policy-agent in Amazon EKS Network Policy Agent before 1.3.7 (VPC CNI before 1.22.3) might allow an authenticated adjacent user to bypass NetworkPolicy ingress enforcement on co-located pods via eBPF conntrack map poisoning using crafted AF_PACKET frames. To remediate this issue, users should upgrade to Amazon VPC CNI Managed Add-on v1.22.3 or later (which includes Network Policy Agent v1.3.7).
What to do
Check whether your setup matches what the bug needs.
Impacted if aws-network-policy-agent is below 1.3.7 or Amazon VPC CNI Managed Add-on is below 1.22.3Upgrade to a fixed version: 1.3.7, 1.22.3.
Timeline
- CVE published
- Record last updated
- First seen by cve.now
Affected versions
- AWS aws-network-policy-agent
fixed in 1.3.7
- AWS amazon-vpc-cni-k8s
fixed in 1.22.3
Evidence 4
- Advisory
- Advisory
- Patch
- Patch
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-122266
Is CVE-2026-122266 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
The flaw lets traffic bypass NetworkPolicy ingress enforcement on co-located pods, so policies meant to restrict incoming traffic to those pods may not be applied as intended.Source: aws.amazon.com
Which versions are affected by CVE-2026-122266?
aws-network-policy-agent: before 1.3.7. amazon-vpc-cni-k8s: before 1.22.3.Source: cve.now feed data
Am I affected, and how do I check?
Versions of aws-network-policy-agent below 1.3.7, and Amazon VPC CNI Managed Add-on below 1.22.3, in Amazon EKS. To check, compare the installed version of each component against these fixed versions.Source: aws.amazon.com
How do I fix CVE-2026-122266?
Upgrade aws-network-policy-agent to 1.3.7 or later, or upgrade the Amazon VPC CNI Managed Add-on to 1.22.3 or later.Source: aws.amazon.com