Skip to main content
← Vulnerabilities

WordPress Pie Register plugin <= 3.8.4.15 - Cross Site Scripting (XSS) vulnerability

7.1HighCNA
Exploited
No known exploitation
Fix
Fixed in 3.8.4.16
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. Pie Register plugin version 3.8.4.15 or earlier (vulnerable versions <= 3.8.4.15).

Published
Last modified
0.18% · 7th percentile
19/100 · provisional
Specific setups only
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

The Pie Register plugin for WordPress has a stored cross-site scripting flaw that lets an attacker inject malicious scripts into web pages the plugin generates. An attacker can reach it remotely without logging in, but a user must take some action before the injected script runs.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

Read the original description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Shamim Rajani Pie Register pie-register allows Stored XSS.This issue affects Pie Register: from n/a through 3.8.4.15.

cve.now Index

19Pcve.now Index 19 of 100 · methodology v3 · provisional
  • Exploitation0/40No signal
  • Exposure12/25Specific setups only, reachable over the network without a login
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity7.1/10CVSS 7.1
  • No patch0/5No signal

What would change the score

  • Would score about 69 if added to CISA KEV
  • Would score about 64 if CISA's SSVC rates exploitation active

What to do

  • Check whether your setup matches what the bug needs.

    Pie Register plugin version 3.8.4.15 or earlier (vulnerable versions <= 3.8.4.15).
  • Upgrade to a fixed version: 3.8.4.16.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  4. Record last updated

Affected versions

  • pie-register

    through 3.8.4.15

Evidence 1

  1. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-119488

Is CVE-2026-119488 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

The Pie Register plugin for WordPress has a cross-site scripting (XSS) flaw. An attacker can inject malicious scripts into affected pages, which can steal visitor data or hijack user accounts.Source: patchstack.com

Which versions are affected by CVE-2026-119488?

pie-register: through 3.8.4.15.Source: cve.now feed data

Am I affected, and how do I check?

Pie Register versions 3.8.4.15 and earlier are affected, from the first release through 3.8.4.15. To check, look at the plugin version shown in the WordPress Plugins screen or the plugin's readme file.Source: patchstack.com

How do I fix CVE-2026-119488?

Update Pie Register to version 3.8.4.16 or later, which contains the fix.Source: patchstack.com