Skip to main content
← Vulnerabilities

Stored XSS via Unsanitized waypoint.icon in Map Marker (insertAdjacentHTML)

Affects wanderer v0.19.2 and earlier. The vendor's own rating is not given, and CVSS scores it 7.6 (high). Fixed in 0.19.3.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

7.6HighCNA
Exploited
No known exploitation
Fix
Fixed in 0.19.3
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. Affected versions are v0.19.2 and earlier of wanderer. The attacker must hold an authenticated account that can create waypoints. A victim must open the affected trail's map view. Federated waypoint data can reach the vulnerable sink.

Published
Last modified
16/100 · provisional
Specific setups only
None on Exploit-DB, Metasploit or GitHub

Summary

Wanderer, a self-hosted trail database for saving and sharing adventures, has a stored cross-site scripting flaw in how it renders map markers from waypoint icon data. A remote attacker with a low-privilege account can store a crafted icon value that runs script in the browser of a user who opens the affected trail map, potentially exposing session tokens or acting as that user.

Read the original description

Wanderer is a self-hosted trail database for saving and sharing adventures. Prior to 0.19.3, an authenticated user can store a crafted waypoint.icon value that createMarkerFromWaypoint() passes into FontawesomeMarker, where insertAdjacentHTML inserts the unvalidated value into map marker markup. Opening the affected trail map executes attacker-controlled script in the viewer's browser, which can expose session tokens or perform actions as the victim. Federated waypoint data can also reach the sink without a local account on the receiving instance. This issue is fixed in version 0.19.3.

cve.now Index

16Pcve.now Index 16 of 100 · methodology v3 · provisional
  • Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
  • Exposure8/25Specific setups only, reachable over the network
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity7.6/10CVSS 7.6
  • No patch0/5No signal

What would change the score

  • Would score about 66 if added to CISA KEV
  • Would score about 61 if CISA's SSVC rates exploitation active
  • Would score about 23 if CISA's SSVC rates it automatable

What to do

  • Check whether your setup matches what the bug needs.

    Affected versions are v0.19.2 and earlier of wanderer. The attacker must hold an authenticated account that can create waypoints. A victim must open the affected trail's map view. Federated waypoint data can reach the vulnerable sink.
  • Upgrade to a fixed version: 0.19.3.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • open-wanderer wanderer

    fixed in 0.19.3

Evidence 4

  1. Advisory
  2. Repository
  3. Repository
  4. Repository

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-62345

Is CVE-2026-62345 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

The waypoint icon value is inserted into the trail map view without sanitization, so attacker-supplied script runs in the browser of each user who opens that trail's map. The facts say this can steal session tokens, perform actions as the victim, or lead to account takeover.Source: github.com

Which versions are affected by CVE-2026-62345?

wanderer: before 0.19.3.Source: cve.now feed data

Am I affected, and how do I check?

Wanderer v0.19.2 and earlier are affected. An attacker needs an authenticated account that can create waypoints, and federated waypoint data can also reach the vulnerable sink without a local account. To check a installation, look up the installed wanderer version and compare it with v0.19.2.Source: github.com

How do I fix CVE-2026-62345?

Upgrade wanderer to 0.19.3 or later, which is the fixed version listed for this vulnerability.Source: github.com