Skip to main content
← Vulnerabilities

Wanderer: Stored XSS via waypoint.name and waypoint.icon in Elevation Profile innerHTML

Wanderer versions before 0.19.3 are affected, including federated waypoints synced from other instances. The fix is in 0.19.3.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

7.6HighCNA
Exploited
No known exploitation
Fix
Fixed in 0.19.3
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. A victim must view a trail's elevation profile. Federated waypoints synced from other instances are also affected, because they are processed without sanitization.

Published
Last modified
16/100 · provisional
Specific setups only
None on Exploit-DB, Metasploit or GitHub

Summary

Wanderer, a self-hosted trail database, has a stored cross-site scripting flaw in its trail elevation profile, where crafted waypoint names and icons are rendered as HTML. An attacker with a low-privilege account can reach it remotely over the network, and it can also be delivered through federated waypoints from other instances, but it requires a victim to view the elevation profile, and the injected script could then access session data or act within the victim's account.

Read the original description

Wanderer is a self-hosted trail database for saving and sharing adventures. Prior to 0.19.3, an authenticated local user can submit crafted waypoint.name and waypoint.icon values that the trail elevation graph interpolates into an innerHTML template in web/src/lib/vendor/maplibre-elevation-profile/elevationprofile.ts without HTML encoding or icon validation. A victim viewing the elevation profile executes the attacker-controlled script in their browser. Separately, federated waypoints can deliver the same malicious fields across instances without requiring the attacker to have a local account on the receiving instance. The script can expose session data or perform actions in the victim's context. This issue is fixed in version 0.19.3.

cve.now Index

16Pcve.now Index 16 of 100 · methodology v3 · provisional
  • Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
  • Exposure8/25Specific setups only, reachable over the network
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity7.6/10CVSS 7.6
  • No patch0/5No signal

What would change the score

  • Would score about 66 if added to CISA KEV
  • Would score about 61 if CISA's SSVC rates exploitation active
  • Would score about 23 if CISA's SSVC rates it automatable

What to do

  • Check whether your setup matches what the bug needs.

    A victim must view a trail's elevation profile. Federated waypoints synced from other instances are also affected, because they are processed without sanitization.
  • Upgrade to a fixed version: 0.19.3.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • open-wanderer wanderer

    fixed in 0.19.3

Evidence 4

  1. Advisory
  2. Repository
  3. Repository
  4. Repository

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-62346

Is CVE-2026-62346 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

The Elevation Profile view inserts a waypoint's name and icon into the page as HTML without sanitizing them. Script stored in a waypoint therefore runs in the browser of any user who views that trail's elevation profile.Source: github.com, github.com

Which versions are affected by CVE-2026-62346?

wanderer: before 0.19.3.Source: cve.now feed data

Am I affected, and how do I check?

Wanderer by open-wanderer, before 0.19.3. Federated waypoints synced from other instances are also affected because they are processed without sanitization. To check a setup, compare the installed Wanderer version with 0.19.3.Source: github.com, github.com

How do I fix CVE-2026-62346?

Upgrade to v0.19.3 or later, which the advisory says contains the security fixes.Source: github.com, github.com

Why do the sources disagree?

The CVSS score of 7.6 (High) is based on a vector string marked network attack (AV:N), but the advisory's description says the issue is local. The sources conflict on the attack vector, and no vendor severity rating is given.Source: github.com, github.com