Skip to main content
← Vulnerabilities

Live Composer < 2.1.23 - Admin+ Stored XSS via Partner Slug

3.5LowCISA-ADP
Exploited
No known exploitation
Fix
Fixed in 2.1.23
Who is exposed
Not reported

Do first: Upgrade to a fixed version: 2.1.23.

Published
Last modified
0.16% · 5th percentile
7/100 · provisional
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Live Composer, a WordPress plugin, does not sanitise or escape some of its custom post type slug settings before using them in front-end links, which lets a high-privilege user such as an admin carry out stored cross-site scripting attacks even where the unfiltered_html capability is disallowed, such as in multisite setups.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

Read the original description

The Live Composer WordPress plugin before 2.1.23 does not sanitise and escape some of its custom post type slug settings before using them in front-end links, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in a multisite setup).

cve.now Index

7Pcve.now Index 7 of 100 · methodology v3 · provisional
  • Exploitation0/40No signal
  • Exposure3/25Reachable over the network · Unknown: No advisory context yet
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity3.5/10CVSS 3.5
  • No patch0/5No signal

What would change the score

  • Would score about 62 if added to CISA KEV
  • Would score about 57 if CISA's SSVC rates exploitation active
  • Would score about 26 if advisories confirm default setups are exposed

What to do

  • Upgrade to a fixed version: 2.1.23.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  4. Record last updated

Affected versions

  • Unknown Live Composer

    fixed in 2.1.23

Evidence 1

  1. Exploit

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2025-15708

Is CVE-2025-15708 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

Which versions are affected by CVE-2025-15708?

Live Composer: before 2.1.23.Source: cve.now feed data

How do I fix CVE-2025-15708?

Upgrade to a fixed version: 2.1.23.Source: cve.now feed data