- Latest release
- Not known: cve.now hasn't read this package's releases
- Newest unaffected release
- Not known without release data
- Advisories
- 15 · 2 critical, 4 high, 7 medium, 1 low
- Registry
- RubyGems
Advisories 15
- CVE-2024-39311Low 1.8
Publify Vulnerable To Cross-Site Scripting (XSS) Via Redirects Requiring User Interaction
Affected: fixed in 10.0.2.
- CVE-2023-0569High 8.1
Weak Password Requirements in publify/publify
Affected: fixed in 9.2.10.
- CVE-2023-0299High 8.4
Improper Input Validation in publify/publify
Affected: fixed in 9.2.10.
- CVE-2022-2815Medium 4.6
Insecure Storage of Sensitive Information in publify/publify
Affected: fixed in 9.2.10.
- CVE-2022-1812High 7.6
Integer Overflow or Wraparound in publify/publify
Affected: fixed in 9.2.10.
- CVE-2022-1811Critical 9.1
Unrestricted Upload of File with Dangerous Type in publify/publify
Affected: fixed in 9.2.9.
- CVE-2022-1810Critical 9.9
Authorization Bypass Through User-Controlled Key in publify/publify
Affected: fixed in 9.2.9.
- CVE-2022-1553High 8.8
Leaking password protected articles content due to improper access control in publify/publify
Affected: fixed in 9.2.8.
- CVE-2022-0578Medium 5.3
Code Injection in publify/publify
Affected: fixed in 9.2.8.
- CVE-2022-0574Medium 5.3
Improper Access Control in publify/publify
Affected: fixed in 9.2.8.
- CVE-2022-0524Medium 6.5
Business Logic Errors in publify/publify
Affected: fixed in 9.2.7.
- CVE-2021-25975Medium 5.4
Publify - Stored Cross-Site Scripting (XSS) due to Unrestricted File Upload
Affected: from 8.0, fixed in 9.2.5.
- CVE-2021-25974Medium 5.4
Publify - Stored Cross-Site Scripting (XSS) in Editor
Affected: from 8.0, fixed in 9.2.5.
- CVE-2021-25973Medium 6.5
Publify - Improper Authorization Leads to Guest Signup Restriction Bypass
Affected: from 9.0.0.pre1, fixed in 9.2.5.
- CVE-2014-3211Unrated
Publify before 8.0.1 is vulnerable to a Denial of Service attack
Affected: fixed in 8.0.1.