Skip to main content
← All vulnerabilities
CVE-2021-25974GHSA-WMH9-X28J-C6GRBIT-PUBLIFY-2021-25974

Publify - Stored Cross-Site Scripting (XSS) in Editor

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 9.2.5
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: no
  • Technical impact: partial

Summary

In Publify, versions v8.0 to v9.2.4 are vulnerable to stored XSS. A user with a “publisher” role is able to inject and execute arbitrary JavaScript code while creating a page/article.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • publify_core publify_core

    From v8.0; through v9.2.4

  • publify_coreRubyGems

    From 8.0 · fixed in 9.2.5

References 2

GitHub · publify/publify

whitesourcesoftware.com