Skip to main content
← All vulnerabilities
CVE-2021-25975GHSA-3H7V-WQW7-FF28BIT-PUBLIFY-2021-25975

Publify - Stored Cross-Site Scripting (XSS) due to Unrestricted File Upload

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 9.2.5
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: no
  • Technical impact: partial

Summary

In publify, versions v8.0 to v9.2.4 are vulnerable to stored XSS as a result of an unrestricted file upload. This issue allows a user with “publisher” role to inject malicious JavaScript via the uploaded html file.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • publify_core publify_core

    From v8.0; through v9.2.4

  • publify_coreRubyGems

    From 8.0 · fixed in 9.2.5

References 2

whitesourcesoftware.com

GitHub · publify/publify