Skip to main content
← RubyGems

jquery-rails

9 known vulnerabilities (2 medium), with the versions each affects and the releases that fix them.

Latest release
Not known: cve.now hasn't read this package's releases
Newest unaffected release
Not known without release data
Advisories
9 · 2 medium
Registry
RubyGems

Advisories 9

  • jquery prior to 1.9.0 allows Cross-site Scripting attacks via the load method.

    Affected: fixed in 2.2.0.

  • CVE-2020-11023Medium 6.9 · KEV

    Potential XSS vulnerability in jQuery

    Affected: fixed in 4.4.0.

  • CVE-2020-11022Medium 6.9

    jQuery has a potential XSS vulnerability

    Affected: fixed in 4.4.0.

  • jQuery before 3.4.0, as used in Drupal, Backdrop CMS, and other products, mishandles jQuery.extend(true, {}, ...) because of…

    Affected: fixed in 4.3.4.

  • jQuery 3.0.0-rc.1 is vulnerable to Denial of Service (DoS) due to removing a logic that lowercased attribute names.

    Affected: from 3.0.0-rc.1, fixed in 3.0.0.

  • jQuery before 3.0.0 is vulnerable to Cross-site Scripting (XSS) attacks when a cross-domain Ajax request is performed without the dataType…

    Affected: fixed in 4.2.0.

  • jQuery before 1.9.0 is vulnerable to Cross-site Scripting (XSS) attacks.

    Affected: fixed in 2.2.0.

  • jquery_ujs.js in jquery-rails before 3.1.3 and 4.x before 4.0.4 and rails.js in jquery-ujs before 1.0.4, as used with Ruby on Rails 3.x…

    Affected: fixed in 3.1.3; from 4.0.0, fixed in 4.0.4.

  • Cross-site scripting (XSS) vulnerability in jQuery before 1.6.3, when using location.hash to select elements, allows remote attackers to…

    Affected: fixed in 1.0.16.