CVE-2020-7656GHSA-Q4M3-2J7H-F7XWSNYK-JS-JQUERY-569619
jquery prior to 1.9.0 allows Cross-site Scripting attacks via the load method.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 1.9.0, 2.2.0
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- 1 on Exploit-DB
Summary
jquery prior to 1.9.0 allows Cross-site Scripting attacks via the load method. The load method fails to recognize and remove "<script>" HTML tags that contain a whitespace character, i.e: "</script >", which results in the enclosed script logic to be executed.
Timeline
- CVE published
- Record last updated
- Public exploit on Exploit-DB
EDB-52141
Affected versions
- n/a jquery
All versions prior to version 1.9.0
- jquerynpm
From 1.2.1 · fixed in 1.9.0
- jQueryNuGet
From 1.2.1 · fixed in 1.9.0
- jquery-railsRubyGems
fixed in 2.2.0
- org.webjars.npm:jqueryMaven
From 1.2.1 · fixed in 1.9.0