Skip to main content
← All vulnerabilities
CVE-2015-9251GHSA-RMXG-73GG-4P98

jQuery before 3.0.0 is vulnerable to Cross-site Scripting (XSS) attacks when a cross-domain Ajax request is performed without the dataType o

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.12.2, 3.0.0, 4.2.0
4 proofs of concept on GitHub

Summary

jQuery before 3.0.0 is vulnerable to Cross-site Scripting (XSS) attacks when a cross-domain Ajax request is performed without the dataType option, causing text/javascript responses to be executed.

Timeline

  1. CVE published
  2. Record last updated
  3. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • n/a n/a

    Version range not reported

  • jquerynpm

    fixed in 1.12.2

  • jQueryNuGet

    fixed in 1.12.2

  • jQueryNuGet

    From 1.12.3 · fixed in 3.0.0

  • jquerynpm

    From 1.12.3 · fixed in 3.0.0

  • jquery-railsRubyGems

    fixed in 4.2.0

  • org.webjars.npm:jqueryMaven

    fixed in 1.12.2

  • org.webjars.npm:jqueryMaven

    From 1.12.3 · fixed in 3.0.0

References 29

securityfocus.com

seclists.org

lists.apache.org

access.redhat.com

lists.opensuse.org

oracle.com

GitHub · jquery/jquery

sw.aveva.com

snyk.io

GitHub · hackgiver/CVE-2015-9251

GitHub · halkichi0308/CVE-2015-9251

GitHub · moften/CVE-2015-9251

GitHub · rox-11/xss