Skip to main content
← npm

lodash

10 known vulnerabilities (2 high, 3 medium), with the versions each affects and the releases that fix them.

Latest release
Not known: cve.now hasn't read this package's releases
Newest unaffected release
Not known without release data
Advisories
10 · 2 high, 3 medium
Weekly downloads
206.5M
Dependents
703.2K
Registry
npm

Advisories 10

  • lodash vulnerable to Code Injection via `_.template` imports key names

    Affected: from 4.0.0, fixed in 4.18.0.

  • CVE-2026-2950Medium 6.5

    lodash vulnerable to Prototype Pollution via array path bypass in `_.unset` and `_.omit`

    Affected: fixed in 4.18.0.

  • CVE-2025-13465Medium 6.9

    Prototype Pollution Vulnerability in Lodash _.unset and _.omit functions

    Affected: from 4.0.0, fixed in 4.17.23.

  • Command Injection

    Affected: fixed in 4.17.21.

  • CVE-2020-28500Medium 5.3

    Regular Expression Denial of Service (ReDoS)

    Affected: from 4.0.0, fixed in 4.17.21.

  • Prototype pollution attack when using _.zipObjectDeep in lodash before 4.17.20.

    Affected: from 3.7.0, fixed in 4.17.19.

  • Versions of lodash lower than 4.17.12 are vulnerable to Prototype Pollution.

    Affected: fixed in 4.17.12.

  • lodash prior to 4.17.11 is affected by: CWE-400: Uncontrolled Resource Consumption.

    Affected: from 4.7.0, fixed in 4.17.11.

  • A prototype pollution vulnerability was found in lodash <4.17.11 where the functions merge, mergeWith, and defaultsDeep can be tricked…

    Affected: fixed in 4.17.11.

  • lodash node module before 4.17.5 suffers from a Modification of Assumed-Immutable Data (MAID) vulnerability via defaultsDeep, merge, and…

    Affected: fixed in 4.17.5.