CVE-2019-1010266GHSA-X5RQ-J2XG-H7QMSNYK-JS-LODASH-73639
lodash prior to 4.17.11 is affected by: CWE-400: Uncontrolled Resource Consumption.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 4.17.11
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
lodash prior to 4.17.11 is affected by: CWE-400: Uncontrolled Resource Consumption. The impact is: Denial of service. The component is: Date handler. The attack vector is: Attacker provides very long strings, which the library attempts to match using a regular expression. The fixed version is: 4.17.11.
Timeline
- CVE published
- Record last updated
Affected versions
- lodash lodash
<4.17.11 [fixed: 4.7.11]
- lodashnpm
From 4.7.0 · fixed in 4.17.11
- lodash-esnpm
From 4.7.0 · fixed in 4.17.11
- lodash-amdnpm
From 4.7.0 · fixed in 4.17.11
- lodash-railsRubyGems
From 4.7.0 · fixed in 4.17.11