CVE-2019-10744GHSA-JF85-CPCP-J695SNYK-JS-LODASH-450202
Versions of lodash lower than 4.17.12 are vulnerable to Prototype Pollution.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 4.17.12, 4.17.14, 4.17.13, 4.6.1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- 2 proofs of concept on GitHub
Summary
Versions of lodash lower than 4.17.12 are vulnerable to Prototype Pollution. The function defaultsDeep could be tricked into adding or modifying properties of Object.prototype using a constructor payload.
Timeline
- CVE published
- Record last updated
Affected versions
- Snyk lodash
All versions prior to 4.17.12
- lodashnpm
fixed in 4.17.12
- lodash-esnpm
fixed in 4.17.14
- lodash-amdnpm
fixed in 4.17.13
- lodash.defaultsdeepnpm
fixed in 4.6.1
- lodash-railsRubyGems
fixed in 4.17.12