- Exploited
- No known exploitation
- Fix
- Fixed in 3.20.1
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 3.20.1.
- Last modified
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 10/100 · provisional
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
The actix-http `encoding::Decoder` stream, used by applications that decode gzip, deflate, Brotli, or Zstandard bodies (including actix-web apps), can expand compressed input into a large buffer before the body size limit applies. An attacker who controls that compressed request or response can exhaust memory and CPU, causing denial of service.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
Read the original description
The encoding::Decoder stream can expand compressed input into a large output buffer before a caller can enforce its body size limit. An attacker who controls a compressed request or response can cause excessive memory allocation and CPU use, resulting in denial of service.
This affects applications that decode untrusted gzip, deflate, Brotli, or Zstandard bodies with the corresponding compression feature enabled.
Upgrade to actix-http 3.20.1 or later and configure Decoder::limit() when using the decoder directly. Actix Web users must also upgrade to actix-web 4.18.2 or later so that extractors pass their limits to the decoder.
cve.now Index
- Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
- Exposure?/25Unknown. No advisory context yet
- Reach10/20Affects crates.io packages
- Severity?/10Unknown. No CVSS score or vendor rating
- No patch0/5No signal
What would change the score
- Would score about 65 if added to CISA KEV
- Would score about 60 if CISA's SSVC rates exploitation active
- Would score about 32 if advisories confirm default setups are exposed
What to do
Upgrade to a fixed version: 3.20.1.
Timeline
- Advisory published
- Record last updated
- First seen by cve.now
Affected versions
- actix-httpcrates.io
From 0.0.0-0 · fixed in 3.20.1
Evidence 3
- Advisory
- Repository
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about RUSTSEC-2026-0448
Is RUSTSEC-2026-0448 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
Which versions are affected by RUSTSEC-2026-0448?
actix-http (crates.io): from 0.0.0-0 before 3.20.1.Source: cve.now feed data
How do I fix RUSTSEC-2026-0448?
Upgrade to a fixed version: 3.20.1.Source: cve.now feed data