Skip to main content
← Vulnerabilities

WordPress Widget Options plugin <= 4.2.5 - Remote Code Execution (RCE) vulnerability

Affects Widget Options plugin for WordPress, version 4.2.5 and earlier. The fix is in version 4.2.6, which the advisory says to update to.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

9.1CriticalCNA
Exploited
No known exploitation
Fix
Fixed in 4.2.6
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. Widget Options plugin version 4.2.5 or earlier

Published
Last modified
0.60% · 48th percentile
18/100
Specific setups only
None on Exploit-DB, Metasploit or GitHub
On X
View the cve.now post
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

The Widget Options plugin for WordPress is affected by this vulnerability. An attacker who can access the affected plugin could potentially run arbitrary code on the server hosting the website.

Read the original description

Author Remote Code Execution (RCE) in Widget Options <= 4.2.5 versions.

cve.now Index

18cve.now Index 18 of 100 · methodology v3
  • Exploitation0/40No signal
  • Exposure8/25Specific setups only, reachable over the network
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity10/10CVSS 9.1, total technical impact per CISA
  • No patch0/5No signal

What would change the score

  • Would score about 68 if added to CISA KEV
  • Would score about 63 if CISA's SSVC rates exploitation active
  • Would score about 25 if CISA's SSVC rates it automatable

What to do

  • Check whether your setup matches what the bug needs.

    Widget Options plugin version 4.2.5 or earlier
  • Upgrade to a fixed version: 4.2.6.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. Posted on X by cve.now
  4. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  5. Record last updated

Affected versions

  • widget-options

    through 4.2.5

Evidence 1

  1. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-116852

Is CVE-2026-116852 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

The flaw lets attackers run any command on the server that hosts the affected plugin, from anywhere in the world.Source: patchstack.com

Which versions are affected by CVE-2026-116852?

widget-options: through 4.2.5.Source: cve.now feed data

Am I affected, and how do I check?

The advisory lists Widget Options plugin version 4.2.5 or earlier as vulnerable. The installed version is shown on the Plugins page of the WordPress admin dashboard.Source: patchstack.com

How do I fix CVE-2026-116852?

Update the Widget Options plugin to version 4.2.6 or later.Source: patchstack.com