WordPress Widget Options plugin <= 4.2.5 - Remote Code Execution (RCE) vulnerability
Affects Widget Options plugin for WordPress, version 4.2.5 and earlier. The fix is in version 4.2.6, which the advisory says to update to.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in 4.2.6
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: no
- Technical impact: total
Summary
The Widget Options plugin for WordPress is affected by this vulnerability. An attacker who can access the affected plugin could potentially run arbitrary code on the server hosting the website.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
Author Remote Code Execution (RCE) in Widget Options <= 4.2.5 versions.
Timeline
- CVE published
- First seen by cve.now
- Posted on X by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: total
- Record last updated
Affected versions
- widget-options
through 4.2.5
References 1
Questions about CVE-2026-116852
What does this mean?
The flaw lets attackers run any command on the server that hosts the affected plugin, from anywhere in the world.Source: patchstack.com
Am I affected, and how do I check?
The advisory lists Widget Options plugin version 4.2.5 or earlier as vulnerable. The installed version is shown on the Plugins page of the WordPress admin dashboard.Source: patchstack.com
What should I do about it?
Update the Widget Options plugin to version 4.2.6 or later.Source: patchstack.com
Is it being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data