Skip to main content
← Vulnerabilities

WordPress Core 4.7.0 - 7.1.3 - Unauthenticated Upgrade-Window Staged-Installer Remote Code Execution

Affects WordPress 4.7.0 through 7.1.3 (every branch from 4.7 up to 7.1), but only while a core upgrade is in progress. Fixed in 7.1.4.

Written by anthropic/claude-sonnet-5.5 from the sources below. Verify against them.

8.1HighCNA
Exploited
Yes, on CISA KEV
Fix
Fixed in 7.1.4
Who is exposed
Not reported

Do first: Upgrade to a fixed version: 7.1.4.

Published
Last modified
1.16% · 67th percentile
88/100 · #35 in the past year
Actively exploited
4 proofs of concept on GitHub
On X
View the cve.now post
  • Exploitation: active
  • Automatable: no
  • Technical impact: total

Summary

WordPress core has a flaw that lets an attacker run code on the server remotely, without logging in, by reaching predictable, web-accessible staging paths while a core upgrade is in progress. Public exploit code exists and the bug is being exploited in attacks.

Read the original description

WordPress Core is vulnerable to Remote Code Execution in versions 4.7 through 7.1.3. This is due to predictable, web-accessible staging paths used during full-package core upgrades. This makes it possible for unauthenticated attackers to execute code on the server during the upgrade window.

cve.now Index

88cve.now Index 88 of 100 · methodology v3
  • Exploitation40/40Listed in CISA's Known Exploited Vulnerabilities catalog
  • Exposure22/25Actively exploited, reachable over the network without a login
  • Reach17/20Affects WordPress (a widely deployed server, runtime, framework or database)
  • Severity9.1/10CVSS 8.1, total technical impact per CISA
  • No patch0/5No signal

Impact

What to do

  • Upgrade to a fixed version: 7.1.4.

  • Fix it by , CISA's deadline for US federal agencies.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. Posted on X by cve.now3 days
  4. CISA SSVC assessment

    Exploitation: active · Automatable: no · Technical impact: total

  5. Added to CISA KEV

    CISA has evidence of exploitation in the wild

    1 day
  6. Record last updated1 day
  7. Exploit code on GitHub

    tc4dy/CVE-2026-119977-Toolkit

    1 day
  8. CISA remediation deadline

    Due date for US federal agencies to patch

Affected versions

  • WordPress Foundation WordPress

    From 4.7.0 · through 4.7.38; From 4.8.0 · through 4.8.33; From 4.9.0 · through 4.9.34; From 5.0.0 · through 5.0.30; From 5.1.0 · through 5.1.27; From 5.2.0 · through 5.2.29; From 5.3.0 · through 5.3.26; From 5.4.0 · through 5.4.24; From 5.5.0 · through 5.5.23; From 5.6.0 · through 5.6.22; From 5.7.0 · through 5.7.20; From 5.8.0 · through 5.8.18; From 5.9.0 · through 5.9.19; From 6.0.0 · through 6.0.17; From 6.1.0 · through 6.1.15; From 6.2.0 · through 6.2.14; From 6.3.0 · through 6.3.13; From 6.4.0 · through 6.4.13; From 6.5.0 · through 6.5.13; From 6.6.0 · through 6.6.10; From 6.7.0 · through 6.7.10; From 6.8.0 · through 6.8.11; From 6.9.0 · through 6.9.10; From 7.0.0 · through 7.0.7; From 7.1.0 · through 7.1.3

On X 10

Evidence 14

  1. Exploit
  2. Exploit
  3. Exploit
  4. Exploit
  5. Link
Show all 14 sourcesShow fewer sources
  1. Link
  2. Link
  3. Link
  4. Link
  5. Link
  6. Link
  7. Link
  8. Link
  9. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-119977

Is CVE-2026-119977 being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2026-11-03, which means it has evidence of attacks. US federal agencies must fix it by 2026-11-06. Public exploit code exists (a proof of concept on GitHub).Source: cisa.gov, cve.now feed data

What does this mean?

A weakness in the WordPress upgrade process can lead to remote code execution on the server during the upgrade window. The advisory describes it as a risk that exists only while a core upgrade is running.Source: wordpress.org

Which versions are affected by CVE-2026-119977?

WordPress: from 4.7.0 through 4.7.38; from 4.8.0 through 4.8.33; from 4.9.0 through 4.9.34; from 5.0.0 through 5.0.30; from 5.1.0 through 5.1.27; from 5.2.0 through 5.2.29; from 5.3.0 through 5.3.26; from 5.4.0 through 5.4.24; from 5.5.0 through 5.5.23; from 5.6.0 through 5.6.22; from 5.7.0 through 5.7.20; from 5.8.0 through 5.8.18; from 5.9.0 through 5.9.19; from 6.0.0 through 6.0.17; from 6.1.0 through 6.1.15; from 6.2.0 through 6.2.14; from 6.3.0 through 6.3.13; from 6.4.0 through 6.4.13; from 6.5.0 through 6.5.13; from 6.6.0 through 6.6.10; from 6.7.0 through 6.7.10; from 6.8.0 through 6.8.11; from 6.9.0 through 6.9.10; from 7.0.0 through 7.0.7; from 7.1.0 through 7.1.3.Source: cve.now feed data

Am I affected, and how do I check?

WordPress versions from 4.7.0 through 7.1.3 are listed, covering each release branch from 4.7 to 7.1, with the last affected release in each branch given in the advisory data. The condition is that a core upgrade is in progress. The installed version is shown in the WordPress dashboard under Updates, or on the About WordPress screen.Source: wordpress.org

How do I fix CVE-2026-119977?

Download WordPress 7.1.4 from WordPress.org and upgrade to it. No workaround is listed in the facts.Source: wordpress.org