WordPress < 7.0.2 - REST API batch-route confusion and SQL injection issue leading to Remote Code Execution
WordPress 6.9.0 through 6.9.4 and 7.0.0 through 7.0.1 are affected. CVSS scores it 9.8 (critical). Fixed in 6.9.5 and 7.0.2.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Actively exploited
- Fix
- Fixed in 6.9.5, 7.0.2
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: active
- Automatable: yes
- Technical impact: total
Summary
WordPress core, the widely used content management system, is affected, specifically its REST API batch endpoint and its WP_Query handling. A flaw in how batch requests are routed, combined with a SQL injection weakness, could allow an attacker to run arbitrary database queries and potentially execute code on the affected server.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
WordPress 6.9.x before 6.9.5 and 7.0.x before 7.0.2 is affected by a REST API batch endpoint route confusion issue which, combined with the author__not_in WP_Query SQL Injection (CVE-2026-60137), could allow an attacker to perform SQL Injection and achieve Remote Code Execution.
Timeline
- CVE published
- Added to CISA KEV
CISA has evidence of exploitation in the wild
- CISA SSVC assessment
Exploitation: active · Automatable: yes · Technical impact: total
- CISA remediation deadline
Due date for US federal agencies to patch
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- WordPress WordPress
From 6.9.0 · fixed in 6.9.5; From 7.0.0 · fixed in 7.0.2
References 2
GitHub · WordPress/wordpress-develop
wordpress.org
Questions about CVE-2026-63030
What does this mean?
The advisory describes a REST API batch-route confusion and SQL injection issue that it says can lead to remote code execution. The provided facts do not give further technical detail about how the bug works.Source: github.com
Am I affected, and how do I check?
WordPress 6.9.0 through 6.9.4 and 7.0.0 through 7.0.1 are listed as affected. To check a site's version, look at the version shown under Dashboard > Updates or in the WordPress version number of the installation.Source: github.com
What should I do about it?
Update 6.9.x installs to 6.9.5 and 7.0.x installs to 7.0.2. The fixes are also included in 7.1 beta2.Source: github.com
Is it being exploited?
Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2026-07-21, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data