Skip to main content
← All vulnerabilities
CVE-2026-60137

WordPress < 7.0.2 - Facilitated SQL Injection via author__not_in in WP_Query

Affects WordPress 6.8.0 through 6.8.5, 6.9.0 through 6.9.4, and 7.0.0 through 7.0.1. Fixed in 6.8.6, 6.9.5, and 7.0.2.

Published
Last modified
published
Listed in CISA KEV
Actively exploited
Fix
Fixed in 6.8.6, 6.9.5, 7.0.2
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: active
  • Automatable: no
  • Technical impact: total

Summary

WordPress, the widely used content management system, is affected, and the flaw lies in its core query handling (WP_Query). If a plugin or theme passes untrusted user input into the author__not_in parameter, an attacker could inject malicious SQL commands, potentially allowing them to read or manipulate the site's database.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

WordPress 6.8.x before 6.8.6, 6.9.x before 6.9.5, and 7.0.x before 7.0.2 does not properly sanitise the author__not_in parameter of WP_Query, which could allow SQL Injection when a plugin or theme passes untrusted input to the parameter.

Timeline

  1. CVE published
  2. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  3. CISA SSVC assessment

    Exploitation: active · Automatable: no · Technical impact: total

  4. CISA remediation deadline

    Due date for US federal agencies to patch

  5. Record last updated

Affected versions

  • WordPress WordPress

    From 6.8.0 · fixed in 6.8.6; From 6.9.0 · fixed in 6.9.5; From 7.0.0 · fixed in 7.0.2

References 2

GitHub · WordPress/wordpress-develop

wordpress.org

FAQ

Questions about CVE-2026-60137

What does this mean?

The bug is a SQL injection flaw in the WP_Query code, reached through the author__not_in parameter. The advisory says that combined with a separate REST API batch-route confusion issue (GHSA-ff9f-jf42-662q), it leads to remote code execution.Source: github.com

Am I affected, and how do I check?

WordPress 6.8.0 through 6.8.5, 6.9.0 through 6.9.4, and 7.0.0 through 7.0.1 are affected. To check a site's version, look at the version shown in the WordPress admin dashboard or the $wp_version value in wp-includes/version.php.Source: github.com

What should I do about it?

Update to the fixed release for your branch: 6.8.6, 6.9.5, or 7.0.2. The advisory lists no workaround.Source: github.com

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2026-07-21, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data