Skip to main content
← All vulnerabilities
CVE-2021-40110GHSA-R58X-WJG8-63M9

Apache James IMAP vulnerable to a ReDoS

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.6.1
None on Exploit-DB, Metasploit or GitHub

Summary

In Apache James, using Jazzer fuzzer, we identified that an IMAP user can craft IMAP LIST commands to orchestrate a Denial Of Service using a vulnerable Regular expression. This affected Apache James prior to 3.6.1 We recommend upgrading to Apache James 3.6.1 or higher , which enforce the use of RE2J regular expression engine to execute regex in linear time without back-tracking.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Apache Software Foundation Apache James

    through 3.6.0

  • org.apache.james:james-serverMaven

    From 3.1.0 · fixed in 3.6.1

References 2

openwall.com