Skip to main content
← Vulnerabilities

GeoNode has Stored XSS in Documents metadata abstract field

6.3MediumCNA
Exploited
No known exploitation
Fix
Fixed in 5.0.3
Who is exposed
Not reported

Do first: Upgrade to a fixed version: 5.0.3.

Published
Last modified
19/100 · provisional
None on Exploit-DB, Metasploit or GitHub

Summary

GeoNode, a geospatial content management system, has a stored cross-site scripting flaw in the abstract field of document metadata. An attacker who can log in with low privileges can remotely plant scripts there that run in another user's browser when that user opens the document page, which requires that user to take an action.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

Read the original description

GeoNode is a geospatial content management system, a platform for the management and publication of geospatial data. Prior to 5.0.3, document abstract metadata is stored without sanitization, allowing a low-privileged remote user to persist arbitrary HTML and JavaScript that executes in another user's browser when the document page is visited. This issue is fixed in version 5.0.3.

cve.now Index

19Pcve.now Index 19 of 100 · methodology v3 · provisional
  • Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
  • Exposure3/25Reachable over the network · Unknown: No advisory context yet
  • Reach10/20Affects PyPI packages
  • Severity6.3/10CVSS 6.3
  • No patch0/5No signal

What would change the score

  • Would score about 74 if added to CISA KEV
  • Would score about 69 if CISA's SSVC rates exploitation active
  • Would score about 38 if advisories confirm default setups are exposed

What to do

  • Upgrade to a fixed version: 5.0.3.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • GeoNode geonode

    fixed in 5.0.3

  • geonodePyPI

    fixed in 5.0.3

Evidence 6

  1. Advisory
  2. Repository
  3. Repository
  4. Repository
  5. Repository
  6. Repository

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-55649

Is CVE-2026-55649 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

Which versions are affected by CVE-2026-55649?

geonode: before 5.0.3. geonode (PyPI): before 5.0.3.Source: cve.now feed data

How do I fix CVE-2026-55649?

Upgrade to a fixed version: 5.0.3.Source: cve.now feed data