WordPress WCFM Membership plugin <= 2.12.0 - Cross Site Scripting (XSS) vulnerability
Affects WCFM Membership plugin (wc-multivendor-membership) version 2.12.0 and earlier, for WordPress sites. Fixed in 2.12.1.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 2.12.1
- Who is exposed
- Specific setups only
Do first: Check whether your setup matches what the bug needs. WCFM Membership plugin version 2.12.0 or earlier (wc-multivendor-membership)
- Last modified
- FIRST's estimate of the chance attackers exploit it in the next 30 days, updated daily.What do these mean? →
- 0.15% · 3rd percentile
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 19/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: no
- Technical impact: partial
Summary
The WCFM Membership plugin for WordPress (WC Lovers wc-multivendor-membership) has a stored cross-site scripting flaw. An attacker can reach it remotely without logging in, but a user must take an action, such as opening a crafted page, before the injected script runs in their browser.
Read the original description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WC Lovers WCFM Membership wc-multivendor-membership allows Stored XSS.This issue affects WCFM Membership: from n/a through 2.12.0.
cve.now Index
- Exploitation0/40No signal
- Exposure12/25Specific setups only, reachable over the network without a login
- Reach?/20Unknown. No tracked technology or package matched
- Severity7.1/10CVSS 7.1
- No patch0/5No signal
What would change the score
- Would score about 69 if added to CISA KEV
- Would score about 64 if CISA's SSVC rates exploitation active
What to do
Check whether your setup matches what the bug needs.
WCFM Membership plugin version 2.12.0 or earlier (wc-multivendor-membership)Upgrade to a fixed version: 2.12.1.
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: partial
- Record last updated
Affected versions
- wc-multivendor-membership
through 2.12.0
Evidence 1
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-39744
Is CVE-2026-39744 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
This is a stored cross-site scripting flaw, which means attackers can inject malicious scripts into the site. Those scripts could steal visitor data or hijack visitor accounts.Source: patchstack.com, cve.org
Which versions are affected by CVE-2026-39744?
wc-multivendor-membership: through 2.12.0.Source: cve.now feed data
Am I affected, and how do I check?
WCFM Membership plugin (wc-multivendor-membership) version 2.12.0 and earlier is in scope. The installed version is shown on the WordPress Plugins screen.Source: patchstack.com, cve.org
How do I fix CVE-2026-39744?
Update the WCFM Membership plugin to version 2.12.1 or later.Source: patchstack.com, cve.org