Skip to main content
← Vulnerabilities

DataEase SVG StaticResourceServer.java StaticResourceServer.validateSvgContent cross site scripting

5.3MediumCNA
Exploited
No known exploitation
Fix
Fix or patch referenced
Who is exposed
Not reported

Do first: Apply the patch listed under Evidence.

Published
Last modified
12/100 · provisional
None on Exploit-DB, Metasploit or GitHub

Summary

DataEase's SVG handler contains a cross-site scripting flaw that can lead to script execution in a victim's browser. An attacker can reach it remotely, without logging in, but a user must take an action for the attack to succeed.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

Read the original description

A flaw has been found in DataEase up to 2.10.27. Affected by this issue is the function StaticResourceServer.validateSvgContent of the file core/core-backend/src/main/java/io/dataease/visualization/server/StaticResourceServer.java of the component SVG Handler. Executing a manipulation can lead to cross site scripting. It is possible to launch the attack remotely. The exploit has been published and may be used. Upgrading to version 2.10.28 can resolve this issue. This patch is called 0709fe98d6608c3507daee3e92cf433e7ff61370. You should upgrade the affected component. The vendor confirms: "The reported tab/entity-based URL bypass is covered by our previously implemented SVG security hardening. The fix replaces the blacklist-based checks with namespace-aware element and attribute allowlists, restricts permitted references to document-local fragments, and applies a restrictive Content Security Policy to uploaded SVG responses."

cve.now Index

12Pcve.now Index 12 of 100 · methodology v3 · provisional
  • Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
  • Exposure7/25Reachable over the network without a login · Unknown: No advisory context yet
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity5.3/10CVSS 5.3
  • No patch0/5No signal

What would change the score

  • Would score about 67 if added to CISA KEV
  • Would score about 62 if CISA's SSVC rates exploitation active
  • Would score about 27 if advisories confirm default setups are exposed

What to do

  • Apply the patch listed under Evidence.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • n/a DataEase

    2.10.0, 2.10.1, 2.10.2, 2.10.3, 2.10.4, 2.10.5, 2.10.6, 2.10.7, 2.10.8, 2.10.9, 2.10.10, 2.10.11, 2.10.12, 2.10.13, 2.10.14, 2.10.15, 2.10.16, 2.10.17, 2.10.18, 2.10.19, 2.10.20, 2.10.21, 2.10.22, 2.10.23, 2.10.24, 2.10.25, 2.10.26, 2.10.27

Evidence 8

  1. Advisory
  2. Advisory
  3. Advisory
  4. Advisory
  5. Patch
Show all 8 sourcesShow fewer sources
  1. Patch
  2. Patch
  3. Repository

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-123992

Is CVE-2026-123992 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

Which versions are affected by CVE-2026-123992?

DataEase: versions 2.10.0, 2.10.1, 2.10.2, 2.10.3, 2.10.4 and 23 more.Source: cve.now feed data