Skip to main content
← Vulnerabilities

WordPress TranslatePress plugin <= 3.3.8 - Cross Site Scripting (XSS) vulnerability

TranslatePress plugin for WordPress, versions 3.3.8 and earlier, is affected. Fixed in 3.3.9.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

7.1HighCNA
Exploited
No known exploitation
Fix
Fixed in 3.3.9
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. Vulnerable versions are 3.3.8 and earlier

Published
Last modified
19/100 · provisional
Specific setups only
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

The WordPress TranslatePress multilingual plugin contains a stored cross-site scripting flaw that lets an attacker inject malicious script into pages. It can be reached remotely without logging in, but a user has to take an action, such as opening a crafted page, for the attack to run.

Read the original description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Cozmoslabs TranslatePress translatepress-multilingual allows Stored XSS.This issue affects TranslatePress: from n/a through 3.3.8.

cve.now Index

19Pcve.now Index 19 of 100 · methodology v3 · provisional
  • Exploitation0/40No signal
  • Exposure12/25Specific setups only, reachable over the network without a login
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity7.1/10CVSS 7.1
  • No patch0/5No signal

What would change the score

  • Would score about 69 if added to CISA KEV
  • Would score about 64 if CISA's SSVC rates exploitation active

What to do

  • Check whether your setup matches what the bug needs.

    Vulnerable versions are 3.3.8 and earlier
  • Upgrade to a fixed version: 3.3.9.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  4. Record last updated

Affected versions

  • translatepress-multilingual

    through 3.3.8

Evidence 1

  1. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-121765

Is CVE-2026-121765 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

The flaw is a cross-site scripting (XSS) bug, which lets malicious scripts be injected into the site. Those scripts can steal visitor data or hijack visitor accounts.Source: patchstack.com

Which versions are affected by CVE-2026-121765?

translatepress-multilingual: through 3.3.8.Source: cve.now feed data

Am I affected, and how do I check?

The vulnerable versions are TranslatePress 3.3.8 and earlier, from Cozmoslabs. The installed version is shown on the Plugins page in the WordPress admin area.Source: patchstack.com

How do I fix CVE-2026-121765?

Update the TranslatePress plugin to version 3.3.9 or later, which resolves the vulnerability.Source: patchstack.com