Skip to main content
← Vulnerabilities

Rustls before 0.23.46 and 0.24.0-dev.1 before 0.24.0-dev.2 Secret Exposure via Debug

4.1MediumCNA
Exploited
No known exploitation
Fix
Fixed in 0.23.46, 0.24.0-dev.2
Who is exposed
Not reported

Do first: Upgrade to a fixed version: 0.23.46, 0.24.0-dev.2.

Published
Last modified
4/100 · provisional
None on Exploit-DB, Metasploit or GitHub

Summary

Rustls before 0.23.46 and 0.24.0-dev.1 before 0.24.0-dev.2 contains an information disclosure vulnerability where derived Debug formatting of client session values exposes secret key material. Custom ClientSessionStore implementations that log Tls12ClientSessionValue or Tls13ClientSessionValue can leak TLS 1.2 master secrets or TLS 1.3 resumption PSKs to log readers.

cve.now Index

4Pcve.now Index 4 of 100 · methodology v3 · provisional
  • Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
  • Exposure?/25Unknown. No advisory context yet
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity4.1/10CVSS 4.1
  • No patch0/5No signal

What would change the score

  • Would score about 59 if added to CISA KEV
  • Would score about 54 if CISA's SSVC rates exploitation active
  • Would score about 26 if advisories confirm default setups are exposed

What to do

  • Upgrade to a fixed version: 0.23.46, 0.24.0-dev.2.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • rustls rustls

    fixed in 0.23.46; From 0.24.0-dev.1 · fixed in 0.24.0-dev.2

Evidence 2

  1. Advisory
  2. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-123609

Is CVE-2026-123609 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

Which versions are affected by CVE-2026-123609?

rustls: before 0.23.46; from 0.24.0-dev.1 before 0.24.0-dev.2.Source: cve.now feed data

How do I fix CVE-2026-123609?

Upgrade to a fixed version: 0.23.46, 0.24.0-dev.2.Source: cve.now feed data