Craft CMS 4.0.0 before 4.18.9 Blind SQL Injection via getNext/getPrev Criteria
Affects Craft CMS 4.0.0 before 4.18.9 and 5.0.0 before 5.11.2 through the control panel. Fixed in 4.18.9 and 5.11.2.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 4.18.9, 5.11.2
- Who is exposed
- Specific setups only
Do first: Check whether your setup matches what the bug needs. Craft CMS 4.0.0 before 4.18.9 or 5.0.0 before 5.11.2 The relational-condition request path renders the elementIds value as a sandboxed object template
- Last modified
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 15/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: no
- Technical impact: partial
Summary
Craft CMS, a content management system, has a blind SQL injection flaw in its template sandbox that lets an attacker read data from the database. An attacker with network access and a low-privilege login, such as an authenticated control panel user, can exploit it without any user interaction.
Read the original description
Craft CMS 4.0.0 before 4.18.9 and 5.0.0 before 5.11.2 contains a blind SQL injection vulnerability because the sandbox-exposed getNext() and getPrev() methods pass arbitrary criteria arrays to Craft::configure() without removing SQL-bearing properties such as orderBy and where. Authenticated control panel users can supply a crafted elementIds value, rendered as a sandboxed template, to obtain a conditional SQL oracle under the Craft database account.
cve.now Index
- Exploitation0/40No signal
- Exposure8/25Specific setups only, reachable over the network
- Reach?/20Unknown. No tracked technology or package matched
- Severity7.1/10CVSS 7.1
- No patch0/5No signal
What would change the score
- Would score about 65 if added to CISA KEV
- Would score about 60 if CISA's SSVC rates exploitation active
- Would score about 22 if CISA's SSVC rates it automatable
What to do
Check whether your setup matches what the bug needs.
Craft CMS 4.0.0 before 4.18.9 or 5.0.0 before 5.11.2 The relational-condition request path renders the elementIds value as a sandboxed object templateUpgrade to a fixed version: 4.18.9, 5.11.2.
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: partial
- Record last updated
Affected versions
- craftcms cms
From 4.0.0 · fixed in 4.18.9
- craftcms cms
From 5.0.0 · fixed in 5.11.2
Evidence 2
- Advisory
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-123489
Is CVE-2026-123489 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
The flaw is a blind SQL injection in the relational-condition request path, which renders the elementIds value as a sandboxed object template. Any control panel user can use it as a reliable yes/no test against the Craft database account, so they can infer database contents one condition at a time.Source: vulncheck.com, github.com
Which versions are affected by CVE-2026-123489?
cms: from 4.0.0 before 4.18.9. cms: from 5.0.0 before 5.11.2.Source: cve.now feed data
Am I affected, and how do I check?
Craft CMS 4.0.0 before 4.18.9 and 5.0.0 before 5.11.2 are in the affected ranges. Check the installed version in composer.lock or the control panel's version information, and note whether the installation has control panel users.Source: vulncheck.com, github.com
How do I fix CVE-2026-123489?
Upgrade to Craft CMS 4.18.9 if on the 4.x line, or to 5.11.2 if on the 5.x line.Source: vulncheck.com, github.com