Wazuh from 4.3.0 before 4.14.9 SSRF via GitHub Module Link Pagination
Affects Wazuh 4.3.0 up to 4.14.9, including GA 4.14.7 and the 5.1.0-alpha0 development build, when the GitHub module is configured with an API token. Fixed in 4.14.9.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- Proof of concept public, per CISA
- Fix
- Fixed in 4.14.9
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 4.14.9.
- Published
- Last modified
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 40/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Unclear
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: poc
- Automatable: no
- Technical impact: partial
Summary
Wazuh versions in the affected range have a server-side request forgery flaw in the GitHub module that trusts unvalidated "next page" URLs returned by the GitHub API. Remote attackers who can control that URL can reach the vulnerability over the network without logging in, causing the manager to send its GitHub API token to attacker-controlled hosts and expose organization repositories and settings.
Read the original description
Wazuh from 4.3.0 before 4.14.9 contains a server-side request forgery vulnerability in the GitHub module (wm_github.c) that trusts unvalidated Link rel="next" pagination URLs. Attackers controlling the next-page URL can make the manager send requests with the GitHub API token to attacker hosts, exposing organization repositories and settings.
cve.now Index
- Exploitation15/40CISA rates a proof of concept as public
- Exposure17/25No login or user action needed, reachable over the network without a login · Unknown: Advisories don't say whether default setups are affected
- Reach?/20Unknown. No tracked technology or package matched
- Severity8.2/10CVSS 8.2
- No patch0/5No signal
What would change the score
- Would score about 70 if added to CISA KEV
- Would score about 65 if CISA's SSVC rates exploitation active
- Would score about 45 if advisories confirm default setups are exposed
What to do
Upgrade to a fixed version: 4.14.9.
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: poc · Automatable: no · Technical impact: partial
- Record last updated
Affected versions
- wazuh wazuh
From 4.3.0 · fixed in 4.14.9
Evidence 3
- Advisory
- Repository
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-112338
Is CVE-2026-112338 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. CISA's SSVC assessment notes a proof of concept exists. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
The GitHub module follows a next-page URL returned by the GitHub API. If an attacker controls that URL, the manager sends its stored GitHub API token to a host the attacker chooses, which is a server-side request forgery.Source: vulncheck.com, github.com
Which versions are affected by CVE-2026-112338?
wazuh: from 4.3.0 before 4.14.9.Source: cve.now feed data
Am I affected, and how do I check?
Wazuh 4.3.0 up to but not including 4.14.9 is affected, and the advisory names GA 4.14.7 and the 5.1.0-alpha0 development build (main @ 6308ccd). The exposed setup is the GitHub module configured with an API token to pull organization audit logs. Check the manager version and whether the GitHub module has a token configured.Source: vulncheck.com, github.com
How do I fix CVE-2026-112338?
Upgrade to Wazuh 4.14.9 or later, which is the fixed version listed for this range. The sources reviewed do not describe a separate workaround.Source: vulncheck.com, github.com