Skip to main content
← Vulnerabilities

Wazuh 4.9.0 before 4.14.9 Authorization Header Override via /api/request

Wazuh dashboard plugins from 4.9.0 before 4.14.9 are affected, for authenticated OpenSearch Dashboards users who can call /api/request. Fixed in 4.14.9.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

8.8HighCNA
Exploited
Proof of concept public, per CISA
Fix
Fixed in 4.14.9
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. Affected wazuh-dashboard-plugins versions from 4.9.0 before 4.14.9 Attacker must be an authenticated OpenSearch Dashboards / Wazuh dashboard user who can call /api/request

Published
Last modified
33/100 · provisional
Specific setups only
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: no
  • Technical impact: total

Summary

Wazuh dashboard plugins from a vulnerable range contain an authorization bypass that lets a logged-in dashboard user reach the Wazuh Manager API over the network. An attacker can override the server-side Authorization header through the /api/request proxy, so they can act as another Manager API identity or send unauthenticated requests upstream.

Read the original description

Wazuh dashboard plugins from 4.9.0 before 4.14.9 contain an authorization bypass vulnerability that allows authenticated dashboard users to override the Manager API Authorization header via the /api/request proxy endpoint. Attackers can supply nested body.headers.Authorization values that replace the server-side session Bearer token, letting them act as another Manager API identity or send unauthenticated upstream requests.

cve.now Index

33Pcve.now Index 33 of 100 · methodology v3 · provisional
  • Exploitation15/40CISA rates a proof of concept as public
  • Exposure8/25Specific setups only, reachable over the network
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity9.8/10CVSS 8.8, total technical impact per CISA
  • No patch0/5No signal

What would change the score

  • Would score about 68 if added to CISA KEV
  • Would score about 63 if CISA's SSVC rates exploitation active
  • Would score about 40 if CISA's SSVC rates it automatable

What to do

  • Check whether your setup matches what the bug needs.

    Affected wazuh-dashboard-plugins versions from 4.9.0 before 4.14.9 Attacker must be an authenticated OpenSearch Dashboards / Wazuh dashboard user who can call /api/request
  • Upgrade to a fixed version: 4.14.9.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. CISA SSVC assessment

    Exploitation: poc · Automatable: no · Technical impact: total

  4. Record last updated

Affected versions

  • wazuh wazuh-dashboard-plugins

    From 4.9.0 · fixed in 4.14.9

Evidence 3

  1. Advisory
  2. Repository
  3. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-112340

Is CVE-2026-112340 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. CISA's SSVC assessment notes a proof of concept exists. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

Nested body.headers.Authorization values sent to /api/request can replace the server-side session Bearer token used for Manager API calls. This can make requests act as another Manager API identity or be sent unauthenticated upstream.Source: vulncheck.com, github.com

Which versions are affected by CVE-2026-112340?

wazuh-dashboard-plugins: from 4.9.0 before 4.14.9.Source: cve.now feed data

Am I affected, and how do I check?

Affected are wazuh-dashboard-plugins versions from 4.9.0 before 4.14.9. The attacker must be an authenticated OpenSearch Dashboards / Wazuh dashboard user who can call /api/request. Check the installed wazuh-dashboard-plugins version to see whether it falls in that range.Source: vulncheck.com, github.com

How do I fix CVE-2026-112340?

Upgrade wazuh-dashboard-plugins to 4.14.9 or later, which is the listed fixed version.Source: vulncheck.com, github.com

Why do the sources disagree?

The description says the issue can send unauthenticated upstream requests, but the CVSS vector records PR:L, meaning low privileges are required. The sources describe the required access differently, and the facts do not resolve which is correct.Source: vulncheck.com, github.com