Skip to main content
← Vulnerabilities

WordPress Elementor Website Builder plugin <= 4.3.5 - Cross Site Scripting (XSS) vulnerability

Affects the Elementor Website Builder WordPress plugin, all versions up to and including 4.3.5. Fixed in 4.3.6.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

7.1HighCNA
Exploited
No known exploitation
Fix
Fixed in 4.3.6
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. Plugin version 4.3.5 or earlier (vulnerable versions are <= 4.3.5).

Published
Last modified
19/100 · provisional
Specific setups only
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

The Elementor Website Builder plugin for WordPress has a reflected cross-site scripting flaw that lets an attacker run malicious scripts in a victim's browser. An attacker can reach it remotely without logging in, but a user must first take an action that triggers the flaw.

Read the original description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Elementor Elementor Website Builder elementor allows Reflected XSS.This issue affects Elementor Website Builder: from n/a through 4.3.5.

cve.now Index

19Pcve.now Index 19 of 100 · methodology v3 · provisional
  • Exploitation0/40No signal
  • Exposure12/25Specific setups only, reachable over the network without a login
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity7.1/10CVSS 7.1
  • No patch0/5No signal

What would change the score

  • Would score about 69 if added to CISA KEV
  • Would score about 64 if CISA's SSVC rates exploitation active

What to do

  • Check whether your setup matches what the bug needs.

    Plugin version 4.3.5 or earlier (vulnerable versions are <= 4.3.5).
  • Upgrade to a fixed version: 4.3.6.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  4. Record last updated

Affected versions

  • elementor

    through 4.3.5

Evidence 1

  1. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-109884

Is CVE-2026-109884 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

The plugin does not properly sanitize some input, so an attacker can inject malicious scripts into pages. Those scripts can run in visitors' browsers and could be used to steal visitor data or take over accounts.Source: patchstack.com

Which versions are affected by CVE-2026-109884?

elementor: through 4.3.5.Source: cve.now feed data

Am I affected, and how do I check?

All versions of the Elementor Website Builder plugin up to and including 4.3.5 are listed as affected. To check, look at the installed plugin version in the WordPress Plugins screen or the plugin's header information.Source: patchstack.com

How do I fix CVE-2026-109884?

Update the Elementor Website Builder plugin to version 4.3.6 or later, which the vendor lists as the fixed release.Source: patchstack.com