Skip to main content
← Vulnerabilities

WordPress Elementor Website Builder plugin <= 4.3.5 - Cross Site Scripting (XSS) vulnerability

7.1HighCNA
Exploited
No known exploitation
Fix
Fixed in 4.3.6
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. WordPress Elementor Website Builder plugin version 4.3.5 or earlier

Published
Last modified
19/100 · provisional
Specific setups only
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

The Elementor Website Builder WordPress plugin, version 4.3.5 and earlier, contains a cross-site scripting flaw that lets an attacker inject malicious scripts into web pages. An attacker can reach it remotely without logging in, but it requires a user to take an action, such as opening a crafted link.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

Read the original description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Elementor Elementor Website Builder elementor allows Code Injection.This issue affects Elementor Website Builder: from n/a through 4.3.5.

cve.now Index

19Pcve.now Index 19 of 100 · methodology v3 · provisional
  • Exploitation0/40No signal
  • Exposure12/25Specific setups only, reachable over the network without a login
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity7.1/10CVSS 7.1
  • No patch0/5No signal

What would change the score

  • Would score about 69 if added to CISA KEV
  • Would score about 64 if CISA's SSVC rates exploitation active

What to do

  • Check whether your setup matches what the bug needs.

    WordPress Elementor Website Builder plugin version 4.3.5 or earlier
  • Upgrade to a fixed version: 4.3.6.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  4. Record last updated

Affected versions

  • elementor

    through 4.3.5

Evidence 1

  1. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2026-109883

Is CVE-2026-109883 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

The plugin fails to properly sanitize some input, so an attacker can inject malicious scripts into pages on the site. Those scripts can steal visitor data or hijack user accounts.Source: patchstack.com

Which versions are affected by CVE-2026-109883?

elementor: through 4.3.5.Source: cve.now feed data

Am I affected, and how do I check?

Versions 4.3.5 and earlier of the Elementor Website Builder WordPress plugin are affected. To check, look at the installed plugin version in the WordPress admin Plugins screen.Source: patchstack.com

How do I fix CVE-2026-109883?

Update the Elementor Website Builder plugin to version 4.3.6 or later.Source: patchstack.com