Skip to main content
← Vulnerabilities

Apache James: SASL OAUTHBEARER do not validate aud in JWT payload if misconfigred

Exploited
No known exploitation
Fix
Fixed in 3.9.1
Who is exposed
Not reported

Do first: Upgrade to a fixed version: 3.9.1.

Published
Last modified
0/100 · provisional
None on Exploit-DB, Metasploit or GitHub

Summary

Apache James mail servers using SASL OAUTHBEARER or XOAUTH2 authentication do not properly check the audience claim in JWT tokens when token introspection is not configured. An attacker with valid credentials could use this to access the mail server even when not authorized to do so.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

Read the original description

Apache James SASL OAuthBearer/XOAUTH2 prior versions 3.9.1 fails to validate correctly AUD claim of JWT payloads when introspection is not configured.

This allows an attacker with valid credentials to access the mail server even if they are not authorized to do so.

We recommend users to upgrade to non vulnerable version that forces explicit configuration of aud claims and forces introspection.

cve.now Index

0Pcve.now Index 0 of 100 · methodology v3 · provisional
  • Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
  • Exposure?/25Unknown. No advisory context yet
  • Reach?/20Unknown. No tracked technology or package matched
  • Severity?/10Unknown. No CVSS score or vendor rating
  • No patch0/5No signal

What would change the score

  • Would score about 55 if added to CISA KEV
  • Would score about 50 if CISA's SSVC rates exploitation active
  • Would score about 22 if advisories confirm default setups are exposed

What to do

  • Upgrade to a fixed version: 3.9.1.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. Record last updated

Affected versions

  • Apache Software Foundation Apache James

    From 3.9.0 · fixed in 3.9.1

Evidence 2

  1. Advisory
  2. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

Questions about CVE-2025-66621

Is CVE-2025-66621 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

Which versions are affected by CVE-2025-66621?

Apache James: from 3.9.0 before 3.9.1.Source: cve.now feed data

How do I fix CVE-2025-66621?

Upgrade to a fixed version: 3.9.1.Source: cve.now feed data