- Latest release
- Not known: cve.now hasn't read this package's releases
- Newest unaffected release
- Not known without release data
- Advisories
- 15 · 2 high, 3 medium, 5 low
- Registry
- RubyGems
Advisories 15
- CVE-2026-73648Medium 5.1
rails-html-sanitizer: Possible XSS vulnerability with certain configurations
Affected: from 1.0.3, fixed in 1.7.1.
- CVE-2024-53985Low 2.3
Possible XSS vulnerability with certain configurations of rails-html-sanitizer 1.6.0
Affected: from 1.6.0, fixed in 1.6.1.
- CVE-2024-53987Low 2.3
Possible XSS vulnerability with certain configurations of rails-html-sanitizer 1.6.0
Affected: from 1.6.0, fixed in 1.6.1.
- CVE-2024-53986Low 2.3
Possible XSS vulnerability with certain configurations of rails-html-sanitizer 1.6.0
Affected: from 1.6.0, fixed in 1.6.1.
- CVE-2024-53988Low 2.3
Possible XSS vulnerability with certain configurations of rails-html-sanitizer 1.6.0
Affected: from 1.6.0, fixed in 1.6.1.
- CVE-2024-53989Low 2.3
Possible XSS vulnerability with certain configurations of rails-html-sanitizer 1.6.0
Affected: from 1.6.0, fixed in 1.6.1.
- CVE-2022-23520Medium 6.1
rails-html-sanitizer contains an incomplete fix for an XSS vulnerability
Affected: fixed in 1.4.4.
- CVE-2022-23519High 7.2
Possible XSS vulnerability with certain configurations of rails-html-sanitizer
Affected: fixed in 1.4.4.
- CVE-2022-23518Medium 6.1
Improper neutralization of data URIs allows XSS in rails-html-sanitizer
Affected: from 1.0.3, fixed in 1.4.4.
- CVE-2022-23517High 7.5
Inefficient Regular Expression Complexity in rails-html-sanitizer
Affected: fixed in 1.4.4.
- CVE-2022-32209Unrated
# Possible XSS Vulnerability in Rails::Html::SanitizerThere is a possible XSS vulnerability with certain configurations of…
Affected: fixed in 1.4.3.
- CVE-2018-3741Unrated
There is a possible XSS vulnerability in all rails-html-sanitizer gem versions below 1.0.4 for Ruby.
Affected: fixed in 1.0.4.
- CVE-2015-7580Unrated
Cross-site scripting (XSS) vulnerability in lib/rails/html/scrubbers.rb in the rails-html-sanitizer gem before 1.0.3 for Ruby on Rails…
Affected: fixed in 1.0.3.
- CVE-2015-7579Unrated
Cross-site scripting (XSS) vulnerability in the rails-html-sanitizer gem 1.0.2 for Ruby on Rails 4.2.x and 5.x allows remote attackers to…
Affected: fixed in 1.0.3.
- CVE-2015-7578Unrated
Cross-site scripting (XSS) vulnerability in the rails-html-sanitizer gem before 1.0.3 for Ruby on Rails 4.2.x and 5.x allows remote…
Affected: fixed in 1.0.3.