Skip to main content
← All vulnerabilities
CVE-2022-23518GHSA-MCVF-2Q2M-X72M

Improper neutralization of data URIs allows XSS in rails-html-sanitizer

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.4.4
None on Exploit-DB, Metasploit or GitHub

Summary

rails-html-sanitizer is responsible for sanitizing HTML fragments in Rails applications. Versions >= 1.0.3, < 1.4.4 are vulnerable to cross-site scripting via data URIs when used in combination with Loofah >= 2.1.0. This issue is patched in version 1.4.4.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • rails rails-html-sanitizer

    From 1.0.3 · fixed in 1.4.4

  • rails-html-sanitizerRubyGems

    From 1.0.3 · fixed in 1.4.4

References 4

GitHub · rails/rails-html-sanitizer

hackerone.com

lists.debian.org