Skip to main content
← RubyGems

openssl

3 known vulnerabilities, with the versions each affects and the releases that fix them.

Latest release
Not known: cve.now hasn't read this package's releases
Newest unaffected release
Not known without release data
Advisories
3
Registry
RubyGems

Advisories 3

  • An issue was discovered in the OpenSSL library in Ruby before 2.3.8, 2.4.x before 2.4.5, 2.5.x before 2.5.2, and 2.6.x before…

    Affected: fixed in 2.0.9; from 2.1.0, fixed in 2.1.2.

  • The decode method in the OpenSSL::ASN1 module in Ruby before 2.2.8, 2.3.x before 2.3.5, and 2.4.x through 2.4.1 allows attackers to cause…

    Affected: fixed in 2.0.0.

  • The openssl gem for Ruby uses the same initialization vector (IV) in GCM Mode (aes-*-gcm) when the IV is set before the key, which makes…

    Affected: fixed in 2.0.0.