Skip to main content
← All vulnerabilities
CVE-2017-14033GHSA-V6RP-3R3V-HF4P

The decode method in the OpenSSL::ASN1 module in Ruby before 2.2.8, 2.3.x before 2.3.5, and 2.4.x through 2.4.1 allows attackers to cause a

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.0.0
None on Exploit-DB, Metasploit or GitHub

Summary

The decode method in the OpenSSL::ASN1 module in Ruby before 2.2.8, 2.3.x before 2.3.5, and 2.4.x through 2.4.1 allows attackers to cause a denial of service (interpreter crash) via a crafted string.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • opensslRubyGems

    fixed in 2.0.0

References 12

access.redhat.com

ruby-lang.org

securitytracker.com

debian.org

lists.debian.org

securityfocus.com

security.gentoo.org