Skip to main content
← RubyGems

jquery-ui-rails

7 known vulnerabilities (4 medium), with the versions each affects and the releases that fix them.

Latest release
Not known: cve.now hasn't read this package's releases
Newest unaffected release
Not known without release data
Advisories
7 · 4 medium
Registry
RubyGems

Advisories 7

  • CVE-2022-31160Medium 6.1

    jQuery UI contains potential XSS vulnerability when refreshing a checkboxradio with an HTML-like initial text label

    Affected: fixed in 8.0.0.

  • CVE-2021-41184Medium 6.5

    XSS in the `of` option of the `.position()` util

    Affected: fixed in 7.0.0.

  • CVE-2021-41183Medium 6.5

    XSS in `*Text` options of the Datepicker widget

    Affected: fixed in 7.0.0.

  • CVE-2021-41182Medium 6.5

    XSS in the `altField` option of the Datepicker widget

    Affected: fixed in 7.0.0.

  • Cross-site scripting (XSS) vulnerability in jQuery UI before 1.12.0 might allow remote attackers to inject arbitrary web script or HTML…

    Affected: fixed in 6.0.0.

  • Cross-site scripting (XSS) vulnerability in the default content option in jquery.ui.tooltip.js in the Tooltip widget in jQuery UI before…

    Affected: fixed in 4.0.0.

  • Cross-site scripting (XSS) vulnerability in jquery.ui.dialog.js in the Dialog widget in jQuery UI before 1.10.0 allows remote attackers to…

    Affected: fixed in 4.0.0.