CVE-2012-6662GHSA-QQXP-XP9V-VVX6
Cross-site scripting (XSS) vulnerability in the default content option in jquery.ui.tooltip.js in the Tooltip widget in jQuery UI before 1.1
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 1.10.0, 4.0.0
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Cross-site scripting (XSS) vulnerability in the default content option in jquery.ui.tooltip.js in the Tooltip widget in jQuery UI before 1.10.0 allows remote attackers to inject arbitrary web script or HTML via the title attribute, which is not properly handled in the autocomplete combo box demo.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- jquery-uinpm
fixed in 1.10.0
- jquery-ui-railsRubyGems
fixed in 4.0.0
- org.webjars.npm:jquery-uiMaven
fixed in 1.10.0
- jQuery.UI.CombinedNuGet
fixed in 1.10.0