Skip to main content
← RubyGems

cgi

5 known vulnerabilities (1 high, 2 medium), with the versions each affects and the releases that fix them.

Latest release
Not known: cve.now hasn't read this package's releases
Newest unaffected release
Not known without release data
Advisories
5 · 1 high, 2 medium
Registry
RubyGems

Advisories 5

  • CVE-2025-27220Medium 4.0

    In the CGI gem before 0.4.2 for Ruby, a Regular Expression Denial of Service (ReDoS) vulnerability exists in the Util#escapeElement method.

    Affected: fixed in 0.3.5.1; from 0.3.6, fixed in 0.3.7; from 0.4.0, fixed in 0.4.2.

  • CVE-2025-27219Medium 5.8

    In the CGI gem before 0.4.2 for Ruby, the CGI::Cookie.parse method in the CGI library contains a potential Denial of Service (DoS)…

    Affected: fixed in 0.3.5.1; from 0.3.6, fixed in 0.3.7; from 0.4.0, fixed in 0.4.2.

  • The cgi gem before 0.1.0.2, 0.2.x before 0.2.2, and 0.3.x before 0.3.5 for Ruby allows HTTP response splitting.

    Affected: from 0.3.0, fixed in 0.3.5; from 0.2.0, fixed in 0.2.2; fixed in 0.1.0.2.

  • CGI.escape_html in Ruby before 2.7.5 and 3.x before 3.0.3 has an integer overflow and resultant buffer overflow via a long string on…

    Affected: from 0.3.0, fixed in 0.3.1; from 0.2.0, fixed in 0.2.1; fixed in 0.1.0.1.

  • CGI::Cookie.parse in Ruby through 2.6.8 mishandles security prefixes in cookie names.

    Affected: from 0.3.0, fixed in 0.3.1; from 0.2.0, fixed in 0.2.1; fixed in 0.1.0.1.