Skip to main content
← All vulnerabilities
CVE-2021-41816GHSA-5CQM-CRXM-6QPV

CGI.escape_html in Ruby before 2.7.5 and 3.x before 3.0.3 has an integer overflow and resultant buffer overflow via a long string on platfor

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 0.3.1, 0.2.1, 0.1.0.1
None on Exploit-DB, Metasploit or GitHub

Summary

CGI.escape_html in Ruby before 2.7.5 and 3.x before 3.0.3 has an integer overflow and resultant buffer overflow via a long string on platforms (such as Windows) where size_t and long have different numbers of bytes. This also affects the CGI gem before 0.3.1 for Ruby.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • cgiRubyGems

    From 0.3.0 · fixed in 0.3.1

  • cgiRubyGems

    From 0.2.0 · fixed in 0.2.1

  • cgiRubyGems

    fixed in 0.1.0.1

References 7

hackerone.com

ruby-lang.org

security-tracker.debian.org

security.netapp.com

lists.fedoraproject.org

security.gentoo.org