Skip to main content
← PyPI

ipython

8 known vulnerabilities (1 high, 1 medium), with the versions each affects and the releases that fix them.

Latest release
Not known: cve.now hasn't read this package's releases
Newest unaffected release
Not known without release data
Advisories
8 · 1 high, 1 medium
Registry
PyPI

Advisories 8

  • CVE-2023-24816Medium 4.5

    set_term_title command injection in ipython

    Affected: fixed in 8.10.0.

  • Execution with Unnecessary Privileges in ipython

    Affected: fixed in 5.11; from 6.0.0, fixed in 7.16.3; from 7.17.0, fixed in 7.31.1; from 8.0.0, fixed in 8.0.1; fixed in 6.0.0rc1; from 6.0.0, fixed in 7.16.3; from 7.17.0, fixed in 7.31.1; from 8.0.0, fixed in 8.0.1.

  • Cross-site scripting (XSS) vulnerability in IPython 3.x before 3.2 allows remote attackers to inject arbitrary web script or HTML via…

    Affected: from 3.0.0, fixed in 3.2.0.

  • Cross-site scripting (XSS) vulnerability in IPython before 3.2 allows remote attackers to inject arbitrary web script or HTML via vectors…

    Affected: fixed in 3.2.0.

  • Cross-site request forgery in the REST API in IPython 2 and 3.

    Affected: from 0.12, fixed in 2.4.1; from 3.0.0, fixed in 3.2.3; fixed in 3.2.1.

  • The editor in IPython Notebook before 3.2.2 and Jupyter Notebook 4.0.x before 4.0.5 allows remote attackers to execute arbitrary…

    Affected: fixed in 3.2.2.

  • Cross-site scripting (XSS) vulnerability in the file browser in notebook/notebookapp.py in IPython Notebook before 3.2.2 and Jupyter…

    Affected: fixed in 3.2.2.

  • IPython Notebook 0.12 through 1.x before 1.2 does not validate the origin of websocket requests, which allows remote attackers to execute…

    Affected: from 0.12, fixed in 1.2.0.