Skip to main content
← All vulnerabilities
CVE-2015-6938PYSEC-2015-26GHSA-4VWQ-X64Q-J4CJPYSEC-2015-24

Cross-site scripting (XSS) vulnerability in the file browser in notebook/notebookapp.py in IPython Notebook before 3.2.2 and Jupyter Noteboo

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 4.0.5, 3.2.2
None on Exploit-DB, Metasploit or GitHub

Summary

Cross-site scripting (XSS) vulnerability in the file browser in notebook/notebookapp.py in IPython Notebook before 3.2.2 and Jupyter Notebook 4.0.x before 4.0.5 allows remote attackers to inject arbitrary web script or HTML via a folder name. NOTE: this was originally reported as a cross-site request forgery (CSRF) vulnerability, but this may be inaccurate.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • notebookPyPI

    From 4.0.0 · fixed in 4.0.5

  • ipythonPyPI

    fixed in 3.2.2

References 10

lists.opensuse.org

GitHub · ipython/ipython

bugzilla.redhat.com

seclists.org

GitHub · jupyter/notebook

lists.fedoraproject.org