- Latest release
- Not known: cve.now hasn't read this package's releases
- Newest unaffected release
- Not known without release data
- Advisories
- 15 · 7 high, 6 medium
- Registry
- Packagist
Advisories 15
- CVE-2026-105830High 8.7
league/commonmark 2.0.0 before 2.10.2 Quadratic DoS via TableStartParser
Affected: from 2.0.0, fixed in 2.10.2.
- CVE-2026-105829Medium 5.3
League CommonMark 1.3.0 before 2.10.2 Stored XSS via DisallowedRawHtml Bypass
Affected: from 1.3.0, fixed in 2.10.2.
- CVE-2024-58382High 8.7
league/commonmark before 2.6.0 Denial of Service via Quadratic Complexity
Affected: fixed in 2.6.0.
- CVE-2026-86434High 8.7
commonmark 2.0.0 through 2.8.3 Denial of Service via Slug Collision
Affected: from 2.0.0, fixed in 2.9.0.
- CVE-2026-86431Medium 6.9
commonmark before 2.9.1 XSS via AttributesExtension form feed bypass
Affected: from 2.7.0, fixed in 2.9.1.
- CVE-2026-86430High 8.7
league/commonmark before 2.9.1 Denial of Service via parsing
Affected: from 0.6.0, fixed in 2.9.1.
- CVE-2026-86429High 8.7
commonmark before 2.9.1 Denial of Service via SmartPunct and Attributes
Affected: from 1.5.0, fixed in 2.9.1.
- CVE-2026-86428High 8.7
commonmark 1.5.0 before 2.10.0 Denial of Service via Attributes
Affected: from 1.5.0, fixed in 2.10.0.
- CVE-2026-71488High 7.5
league/commonmark: Quadratic-time denial of service when parsing crafted Markdown
Affected: from 0.6.0, fixed in 2.9.0.
- CVE-2026-71478Medium 6.1
league/commonmark: AttributesExtension href/src unsafe-link filter bypass via embedded control bytes
Affected: from 1.5.0, fixed in 2.9.0.
- CVE-2026-33347Medium 6.3
league/commonmark has an embed extension allowed_domains bypass
Affected: from 2.3.0, fixed in 2.8.2.
- CVE-2026-30838Medium 5.1
league/commonmark: DisallowedRawHtml extension bypass via whitespace in HTML tag names
Affected: from 2.0.0, fixed in 2.8.1.
- CVE-2025-46734Medium 6.4
league/commonmark Cross-site Scripting vulnerability in Attributes extension
Affected: from 1.5.0, fixed in 2.7.0.
- CVE-2019-10010Unrated
Cross-site scripting (XSS) vulnerability in the PHP League CommonMark library before 0.18.3 allows remote attackers to insert unsafe links…
Affected: fixed in 0.18.3.
- CVE-2018-20583Unrated
Cross-site scripting (XSS) vulnerability in the PHP League CommonMark library versions 0.15.6 through 0.18.x before 0.18.1 allows remote…
Affected: from 0.15.6, fixed in 0.18.1.