Skip to main content
← All vulnerabilities
CVE-2018-20583GHSA-QX76-C53F-5C7Q

Cross-site scripting (XSS) vulnerability in the PHP League CommonMark library versions 0.15.6 through 0.18.x before 0.18.1 allows remote att

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 0.18.1
None on Exploit-DB, Metasploit or GitHub

Summary

Cross-site scripting (XSS) vulnerability in the PHP League CommonMark library versions 0.15.6 through 0.18.x before 0.18.1 allows remote attackers to insert unsafe URLs into HTML (even if allow_unsafe_links is false) via a newline character (e.g., writing javascript as javascri%0apt).

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • league/commonmarkPackagist

    From 0.15.6 · fixed in 0.18.1

References 3

commonmark.thephpleague.com

GitHub · thephpleague/commonmark