Skip to main content
← npm

qs

10 known vulnerabilities (1 high, 5 medium, 1 low), with the versions each affects and the releases that fix them.

Latest release
Not known: cve.now hasn't read this package's releases
Newest unaffected release
Not known without release data
Advisories
10 · 1 high, 5 medium, 1 low
Registry
npm

Advisories 10

  • CVE-2026-110816Medium 5.3

    qs.stringify with arrayFormat comma throws TypeError on array elements that cannot be coerced to a string

    Affected: from 6.7.0, fixed in 6.16.1.

  • qs.parse does not enforce arrayLimit on comma groups under bracket-push keys when throwOnLimitExceeded is set (incomplete fix for…

    Affected: from 6.14.2, fixed in 6.16.0.

  • CVE-2026-82417Medium 5.3

    qs.stringify throws TypeError on objects with a non-callable constructor.isBuffer property

    Affected: from 2.2.5, fixed in 6.16.0.

  • CVE-2026-8723Medium 5.3

    qs.stringify crashes on null/undefined entries in comma-format arrays under encodeValuesOnly

    Affected: from 6.11.1, fixed in 6.15.2.

  • CVE-2026-2391Medium 6.3

    qs's arrayLimit bypass in comma parsing allows denial of service

    Affected: from 6.7.0, fixed in 6.14.2.

  • CVE-2025-15284Medium 6.3

    arrayLimit bypass in bracket notation allows DoS via memory exhaustion

    Affected: fixed in 6.14.1.

  • qs before 6.10.3, as used in Express before 4.17.3 and other products, allows attackers to cause a Node process hang for an Express…

    Affected: from 6.10.0, fixed in 6.10.3; from 6.9.0, fixed in 6.9.7; from 6.8.0, fixed in 6.8.3; from 6.7.0, fixed in 6.7.3; from 6.6.0, fixed in 6.6.1; from 6.5.0, fixed in 6.5.3; from 6.4.0, fixed in 6.4.1; from 6.3.0, fixed in 6.3.3; fixed in 6.2.4.

  • The qs module before 1.0.0 does not have an option or default for specifying object depth and when parsing a string representing a deeply…

    Affected: fixed in 1.0.0.

  • the web framework using ljharb's qs module older than v6.3.2, v6.2.3, v6.1.2, and v6.0.4 is vulnerable to a DoS.

    Affected: fixed in 6.0.4; from 6.1.0, fixed in 6.1.2; from 6.2.0, fixed in 6.2.3; from 6.3.0, fixed in 6.3.2.

  • The qs module before 1.0.0 in Node.js does not call the compact function for array data, which allows remote attackers to cause a denial…

    Affected: fixed in 1.0.0.