CVE-2017-1000048GHSA-GQGV-6JQ5-JJJ9
the web framework using ljharb's qs module older than v6.3.2, v6.2.3, v6.1.2, and v6.0.4 is vulnerable to a DoS.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 6.0.4, 6.1.2, 6.2.3, 6.3.2
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
the web framework using ljharb's qs module older than v6.3.2, v6.2.3, v6.1.2, and v6.0.4 is vulnerable to a DoS. A malicious user can send a evil request to cause the web framework crash.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- qsnpm
fixed in 6.0.4
- qsnpm
From 6.1.0 · fixed in 6.1.2
- qsnpm
From 6.2.0 · fixed in 6.2.3
- qsnpm
From 6.3.0 · fixed in 6.3.2